Hate to ask - weird puts/gets error

Sorry, I didn’t want to be back here today.
Having a problem with some interaction , basically things just freeze
up. This is in Scite. I tried the same code in irb , everything is
fine.

print 'Enter birth year: 0000 ’
byear = gets.chomp
print 'Enter month: 1-12 ’
bmonth = gets.chomp
print 'Enter date: ’
bday = gets.chomp <------right after I hit enter on this
print = 'Enter hour: ’ <-------hangs, never asking for hour, if I hit
enter a few times
bhour = gets.chomp
print 'Enter minute: '<------it goes immediately to this
bminute = gets.chomp
print 'Enter seconds ’
bsecond = gets.chomp

bddate = Time.mktime(byear,bmonth,bday,bhour,bminute,bsecond)

Weird ?
Any idea ? I really hope this isn’t a typo that a dozen reads hasn’t
revealed.

TIA
Stuart

Hate to say it, but it is a typo:

print = 'Enter hour: ’

Note that = sign that isn’t supposed to be there. If it helps, I
ended up copying it by hand, finding my version worked, and
vimdiff’ing the two files before I saw it.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs