Has any one seen this error message


#1

I am truying to install the plugin (“ruby script/plugin install
engines”). But I get this big error. Any help?

D:\develop\Ruby\workspace\a2>ruby script/plugin install engines
script/plugin: No such file or directory - svn --version
script/plugin: No such file or directory - svn ls
http://dev.rubyonrails.com/svn
/rails/plugins/
d:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:313:in
plugin s': private methodsplit’ called for nil:NilClass (NoMethodError)
from
d:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:3
21:in each' from d:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:2 38:infind_plugin’
from
d:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:2
37:in each' from d:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:2 37:infind_plugin’
from
d:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:6
96:in parse!' from d:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:6 92:ineach’
from
d:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:6
92:in parse!' from d:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:4 11:inparse!’
from
d:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:4
27:in parse!' from d:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:8 23 from d:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:inre
quire__’
from
d:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in re quire' from d:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_suppo rt/dependencies.rb:214:inrequire’
from script/plugin:3

Thanks


#2

thila thila wrote:

D:\develop\Ruby\workspace\a2>ruby script/plugin install engines

If you’re doing cut-n-paste, is “ruby script/plugin install engines” a
linux command? The “/” in the path leads me to think it is, and you’re
obviously using Windows…

Alternately, are you sure you have a “script/plugin” directory? I had a
similar problem where I had the “script” directory, but no “plugin”
sub-directory.


#3

do you have subversion installed in your dev box ?