GRC Start Up Frozen

Hey guys,
On Ubuntu 12.10 yesterday I was compiling some small pieces of code in
terminal for syntax debugging, installing the files, and then testing
functionality in grc.
So the last thing I did was I install what I am working on (op25). Then
I tried to start the grc but the start got stuck or kind of just froze
after the boost thing that came up in the terminal, no error, just
froze. And after that I noticed some weirdness with filenames
associated with gnuradio. For example I now have file names like
Gr-baz.20130719004000 and rtl-sdr.20130719005437 and there were a couple
of gnuradio folders like that. So I tried my best to uninstall
gnuradio, I used the uninstall script and manually removed what I could
find in the usr directory. I rebuilt from the source file. In
the rebuild I had to skip the make test because one test (out of 180
tests) failed, I am pretty sure it is was a volk something. Now upon
running the ‘sudo gnuradio-companion’ the start freezes (not dies) up
with a message box: cannot open shared

Cannot import gnuradio.

Is the python path environment variable set correctly?

Is the library path environment variable set correctly?
Windows: PATH

The pythonpath is set. I did it myself in the bashrc file. I don’t
know what the library path is. Any guidance on how to get my gnuradio
back will be much appreciated.

Matt D

On 07/19/2013 10:36 AM, Matt D wrote:

of gnuradio folders like that. So I tried my best to uninstall

back will be much appreciated.

Re-run build-gnuradio

those “rtl-sdr.YYMMDD” files are the previous instances of the source
code pulls from git. The script will clean them up if they’re taking up
too much space.

Once you’ve re-built everything with build-gnurado, then I’d suggest
editing your “.grc” file to remove any history of files you might
have been working on, and try again.

Marcus L.
Principal Investigator
Shirleys Bay Radio Astronomy Consortium