GRC problem: window turns grey after executed

Hi all:

I am using GRC 3.3 on ubuntu 10.10. After I “generate” and “execute” the
flow diagram, the graphical sink window will show up (e.g. FFT skin or
Scope
sink). However, everything in this window will turn grey after a few
seconds
and I am not able to click any button in the window. When I tried to
close
it , it says “The window … is not responding”.

Does anyone have the same problem? Please help!!

Thanks a lot!

Rachel

Hi Rachel, this looks like a system overload. The source generates too
much data so that the cpu will not leave any cycles for the rest of the
application.

In the category “misc” there’s a block called “throttle”. Use it before
the FFT block. It will reduce the number of samples that will go into
the FFT. So the FFT function has less work.

I also recently got involved with gnuradio the first time. Have a look
here:

http://www.csun.edu/~skatz/katzpage/sdr_project/sdr/grc_tutorial1.pdf
*
http://www.csun.edu/~skatz/katzpage/sdr_project/sdr/grc_tutorial2.pdf
*
http://www.csun.edu/~skatz/katzpage/sdr_project/sdr/grc_tutorial3.pdf
*
http://www.csun.edu/~skatz/katzpage/sdr_project/sdr/grc_tutorial4.pdf
*

This is a fantastic tutorial that should help you around these hurdles.

BR
Markus
dl8rds

Am Dienstag, den 02.11.2010, 13:05 -0400 schrieb Rachel Li:

Problem solved. Thanks a lot, Markus!!

Also, thanks for sharing this tutorial. I happened to find it yesterday
too
and found It extremely helpful!

Rachel

turn off desktop effects and see if that makes a difference -josh

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs