Graticule error?

I’ve been wanting to just play around with graticule but i cant seem to
get it to work properly.

require ‘rubygems’
require ‘graticule’

module Graticule

geocoder = Graticule.service(:google).new “api_key”
grid = geocoder.locate “1100 N. GRAND AVENUE, WALNUT, CA”
puts “Long/Lat = #{grid.coordinates}”
puts “Grid Location Country = #{grid.country}”
end

############
Outputs ----

C:\Documents and Settings\User\Desktop>grid.rb
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/active_support/clean_logg
er.rb:5:in remove_const': constant Logger::Format not defined (NameError) from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/active_suppo rt/clean_logger.rb:5 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inge
m_original_require’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in re quire' from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/active_suppo rt.rb:31 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inge
m_original_require’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in re quire' from c:/ruby/lib/ruby/gems/1.8/gems/graticule-0.2.6/lib/graticule.rb:3 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:inge
m_original_require’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `re
quire’
from C:/Documents and Settings/User/Desktop/grid.rb:2

C:\Documents and Settings\User\Desktop>grid.rb > text.txt
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/active_support/clean_logg
er.rb:5:in remove_const': constant Logger::Format not defined (NameError) from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/active_suppo rt/clean_logger.rb:5 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inge
m_original_require’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in re quire' from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/active_suppo rt.rb:31 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inge
m_original_require’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in re quire' from c:/ruby/lib/ruby/gems/1.8/gems/graticule-0.2.6/lib/graticule.rb:3 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:inge
m_original_require’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `re
quire’
from C:/Documents and Settings/User/Desktop/grid.rb:2

########

Ive been trying to pull this off in rails as well but its a work in
progress. Any ideas?

Thanks!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs