GR-UHD detected ABI compatibility mismatch with UHD library

Hi all,
I’m having an error when compiling the grc. i was just trying to do a
FFT
on a usrp source and it gives me this error:


Using Volk machine: avx_64_mmx
Traceback (most recent call last):
File “/home/tojo/top_block.py”, line 118, in
tb = top_block()
File “/home/tojo/top_block.py”, line 81, in init
channels=range(1),
File
“/usr/local/lib/python2.7/dist-packages/gnuradio/uhd/init.py”,
line 122, in constructor_interceptor
return old_constructor(*args)
File
“/usr/local/lib/python2.7/dist-packages/gnuradio/uhd/uhd_swig.py”,
line 1727, in make
return _uhd_swig.usrp_source_make(*args)
RuntimeError:
GR-UHD detected ABI compatibility mismatch with UHD library.
GR-UHD was build against ABI: 3.4.0-3,
but UHD library reports ABI: 3.4.0-0
Suggestion: install an ABI compatible version of UHD,
or rebuild GR-UHD component against this ABI version.

I installed the latest UHD version
003.005.003http://files.ettus.com/binaries/uhd_stable/releases/uhd_003.005.003-release/
and gnuradio 3.6.4.1.
Do you know how i can fix this error?

Best Regards,

Antnio Joo Matos Gomes

Hi Antnio,

To fix this error you need to build and install GNU Radio again which
will
compile gr-uhd against the currently installed version of the UHD.

Regards,

Mike


Mike J. M0MIK BSc MIET
Ettus R. Technical Support
Email: [email protected]
Web: http://www.ettus.com http://www.ettus.com

Hi Antnio,

This is what I would do to get out of your predicament:

  1. Uninstall all GNU Radio and UHD packages from the Ubuntu software
    center.
  2. Run Marcus L.'s build-gnuradio script which will compile and build
    the latest release of GNU Radio 3.6 along with the latest stable UHD
    release:

http://gnuradio.org/redmine/projects/gnuradio/wiki/InstallingGR#Using-the-build-gnuradio-script

Regards,

Mike


Mike J. M0MIK BSc MIET
Ettus R. Technical Support
Email: [email protected]
Web: http://www.ettus.com http://www.ettus.com

Well, I need 3.7 due to some other packages I am using. So I guess
gr-air-modes is not yet ported to 3.7?

Ralph.

From: [email protected]lid
[mailto:[email protected]lid] On Behalf Of
Mike
Jameson
Sent: Tuesday, September 17, 2013 3:28 PM
To: Antnio G.
Cc: [email protected]
Subject: Re: [Discuss-gnuradio] GR-UHD detected ABI compatibility
mismatch
with UHD library

Hi Antnio,

This is what I would do to get out of your predicament:

  1. Uninstall all GNU Radio and UHD packages from the Ubuntu software
    center.

  2. Run Marcus L.'s build-gnuradio script which will compile and build
    the
    latest release of GNU Radio 3.6 along with the latest stable UHD
    release:

http://gnuradio.org/redmine/projects/gnuradio/wiki/InstallingGR#Using-the-bu
ild-gnuradio-script

Regards,

Mike


Mike J. M0MIK BSc MIET
Ettus R. Technical Support
Email: [email protected]
Web: http://www.ettus.com

On Tue, Sep 17, 2013 at 1:57 PM, Antnio G. [email protected]
wrote:

I tried to reinstall it again but it’s giving me the exact same error.
I’m
using a gnuradio_3.6.4.1_Ubuntu-12.10-x86_64.deb file with ubuntu
software
center on a UBUNTU 13.04.


Antnio Joo Matos Gomes

2013/9/17 Mike J. [email protected]

Hi Antnio,

To fix this error you need to build and install GNU Radio again which
will
compile gr-uhd against the currently installed version of the UHD.

Regards,

Mike


Mike J. M0MIK BSc MIET
Ettus R. Technical Support
Email: [email protected]
Web: http://www.ettus.com

On Tue, Sep 17, 2013 at 1:27 PM, Antnio G. [email protected]
wrote:

Hi all,

I’m having an error when compiling the grc. i was just trying to do a
FFT on
a usrp source and it gives me this error:


Using Volk machine: avx_64_mmx

Traceback (most recent call last):

File “/home/tojo/top_block.py”, line 118, in

tb = top_block()

File “/home/tojo/top_block.py”, line 81, in init

channels=range(1),

File
“/usr/local/lib/python2.7/dist-packages/gnuradio/uhd/init.py”,
line 122, in constructor_interceptor

return old_constructor(*args)

File
“/usr/local/lib/python2.7/dist-packages/gnuradio/uhd/uhd_swig.py”,
line 1727, in make

return _uhd_swig.usrp_source_make(*args)

RuntimeError:

GR-UHD detected ABI compatibility mismatch with UHD library.

GR-UHD was build against ABI: 3.4.0-3,

but UHD library reports ABI: 3.4.0-0

Suggestion: install an ABI compatible version of UHD,

or rebuild GR-UHD component against this ABI version.


I installed the latest UHD version
<http://files.ettus.com/binaries/uhd_stable/releases/uhd_003.005.003-release
/> 003.005.003 and gnuradio 3.6.4.1.

Do you know how i can fix this error?

Best Regards,


Antnio Joo Matos Gomes

sorry, wrong thread, forget my last mail :slight_smile:

From: [email protected]lid
[mailto:[email protected]lid] On Behalf Of
Mike
Jameson
Sent: Tuesday, September 17, 2013 3:28 PM
To: Antnio G.
Cc: [email protected]
Subject: Re: [Discuss-gnuradio] GR-UHD detected ABI compatibility
mismatch
with UHD library

Hi Antnio,

This is what I would do to get out of your predicament:

  1. Uninstall all GNU Radio and UHD packages from the Ubuntu software
    center.

  2. Run Marcus L.'s build-gnuradio script which will compile and build
    the
    latest release of GNU Radio 3.6 along with the latest stable UHD
    release:

http://gnuradio.org/redmine/projects/gnuradio/wiki/InstallingGR#Using-the-bu
ild-gnuradio-script

Regards,

Mike


Mike J. M0MIK BSc MIET
Ettus R. Technical Support
Email: [email protected]
Web: http://www.ettus.com

On Tue, Sep 17, 2013 at 1:57 PM, Antnio G. [email protected]
wrote:

I tried to reinstall it again but it’s giving me the exact same error.
I’m
using a gnuradio_3.6.4.1_Ubuntu-12.10-x86_64.deb file with ubuntu
software
center on a UBUNTU 13.04.


Antnio Joo Matos Gomes

2013/9/17 Mike J. [email protected]

Hi Antnio,

To fix this error you need to build and install GNU Radio again which
will
compile gr-uhd against the currently installed version of the UHD.

Regards,

Mike


Mike J. M0MIK BSc MIET
Ettus R. Technical Support
Email: [email protected]
Web: http://www.ettus.com

On Tue, Sep 17, 2013 at 1:27 PM, Antnio G. [email protected]
wrote:

Hi all,

I’m having an error when compiling the grc. i was just trying to do a
FFT on
a usrp source and it gives me this error:


Using Volk machine: avx_64_mmx

Traceback (most recent call last):

File “/home/tojo/top_block.py”, line 118, in

tb = top_block()

File “/home/tojo/top_block.py”, line 81, in init

channels=range(1),

File
“/usr/local/lib/python2.7/dist-packages/gnuradio/uhd/init.py”,
line 122, in constructor_interceptor

return old_constructor(*args)

File
“/usr/local/lib/python2.7/dist-packages/gnuradio/uhd/uhd_swig.py”,
line 1727, in make

return _uhd_swig.usrp_source_make(*args)

RuntimeError:

GR-UHD detected ABI compatibility mismatch with UHD library.

GR-UHD was build against ABI: 3.4.0-3,

but UHD library reports ABI: 3.4.0-0

Suggestion: install an ABI compatible version of UHD,

or rebuild GR-UHD component against this ABI version.


I installed the latest UHD version
<http://files.ettus.com/binaries/uhd_stable/releases/uhd_003.005.003-release
/> 003.005.003 and gnuradio 3.6.4.1.

Do you know how i can fix this error?

Best Regards,


Antnio Joo Matos Gomes

Hi Antnio,

I’d recommend building GNU Radio 3.7 if you are starting a fresh. Also,
use
‘-v’ for more information on what it is doing in case of a hang like you
have seen:

build-gnuradio -m -v

If the build-gnuradio script does not work for you you can try pyBombs:

http://gnuradio.org/redmine/projects/gnuradio/wiki/InstallingGR#Using-PyBOMBS

After downloading from Git, navigate to the pybombs folder and run:

sudo ./pybombs install gnuradio

Regards,

Mike


Mike J. M0MIK BSc MIET
Ettus R. Technical Support
Email: [email protected]
Web: http://www.ettus.com http://www.ettus.com

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs