Gr-specest dependencies

There are several dependencies for gr-specest not included in the recipe
for pybombs and some not listed in the gr-specest list of dependencies
but
implied by the text. The recipe for gr-specest in pybombs doesn’t
include
liblapack-dev, libblas-dev, and libarmadillo-dev.

These include the list form the readme

Howto build:

In order to sucessfully build the gr-specest modules you will need:
* cmake > 2.8
* swig
* libgnuradio-core
* libuhd
* gfortran (others might work as well, not tested)
* liblapack-dev
* libblas-dev

but it will not compile, giving you an error about not finding BLAS and
then you fix it by including armadillo which the readme wishes was
deprecated, but most certainly is not.

include:

libarmadillo-dev on Ubuntu.

Now, to construct some use cases that others can use like a guide post 
to
what should be one of the most important gnuradio add-ons and wish I 
hope
will help others use it.

I will post stuff to my blog when it is ready.

Bob

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs