Gr-qtgui working?

I’m trying to get ‘gr-qtgui’ to work on OSX (10.4, but doesn’t really
matter), and have finally figured out that I need QT 3 (not 4, at
least on OSX the way QT4 gets installed, even though the .m4 script
looks for >= 3.3) and QWT 4 or 5 paired with it (qwt 5.0.2 is the
latest, so I’m using that). I have to set QWT_CFLAGS, but that’s
pretty simple to deal with. Now that I have QT and QWT, correct
versions, installed, doing “make” in that module results in:
++++++++++
Making all in gr-qtgui
Making all in src
Making all in lib
make all-am
[snip]
fftdisplay.cc:68:2: warning: #warning Pass the axis info as necessary…
fftdisplay.cc:122:2: warning: #warning Add code here for handling
magnitude, scaling, etc…
[snip]
qt_examples.cc:13:2: warning: #warning Must make this threadsafe
[snip]
/bin/sh …/…/…/libtool --tag=CXX --mode=link g++ -g -O2 -Wall -
Woverloaded-virtual -L/opt/local/lib -o qt_examples fftdisplay.o
qt_examples.o moc_fftdisplay.o -lqwt -framework Carbon -framework
QuickTime -framework OpenGL -framework AGL -L/opt/local/lib -lqt-mt -
lmng -ljpeg -lpng -lz …/…/…/gnuradio-core/src/lib/libgnuradio-
core.la
libtool: link: cannot find the library ' or unhandled argumentCarbon’
make[5]: *** [qt_examples] Error 1
++++++++++
The ‘Carbon’ and related stuff comes from the qt.pc pkg-config file,
which looks OK when editing under Emacs (no strange characters). All
of the above looks OK to me … but clearly it doesn’t compile
cleanly on OSX. And I assume it’s an OSX issue? I haven’t tried
this on Linux yet.

Is anyone still maintaining this module? What’s up with the
#warning’s? Unfinished code? It looks like the latest significant
change was in March’07.

Is QWT/QT better for going graphics than WX? Being an OSX user, I
prefer Aqua-native if at all possible, but since that requires it’s
own OSX specific module and coding which would take significant time
on my part, that’s probably not going to happen. Thus looking at a
more OS-neutral alternative: tk, qwt/qt, wx, whatever … I have
experience with WX only because of GNU Radio, but I have no
experience with the others.

Michael D. wrote:

I’m trying to get ‘gr-qtgui’ to work on OSX (10.4, but doesn’t really
matter), and have finally figured out that I need QT 3 (not 4, at
least on OSX the way QT4 gets installed, even though the .m4 script
looks for >= 3.3) and QWT 4 or 5 paired with it (qwt 5.0.2 is the
latest, so I’m using that). I have to set QWT_CFLAGS, but that’s
pretty simple to deal with. Now that I have QT and QWT, correct
versions, installed, doing “make” in that module results in:

This code is not currently maintained and never really did anything,
unfortunately.

Matt

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs