Gr-osmosdr - No RTL2832 Source Block

Hi List,

I’ve recently been trying to get gnuradio-3.6.5 to talk to my
RTL2832-based
tuner dongle. I installed gr-osmosdr, and all of the blocks seem to
load
fine in gnuradio-companion. Except for one, the rtl2832 source block.
Every time I run some code that uses osmosdr.source, I end up with this
traceback:

Traceback (most recent call last):
File “./rtl_flex_noX.py”, line 123, in
tb = app_top_block(options, queue)
File “./rtl_flex_noX.py”, line 45, in init
self.u = osmosdr.source( args="%s"%(options.device) )
AttributeError: ‘module’ object has no attribute ‘source’

I tried installing gr-baz (as per this post on Reddit:
http://www.reddit.com/r/RTLSDR/comments/sn4t2/how_does_one_get_rtl_as_source_in_gnu/)
http://www.reddit.com/r/RTLSDR/comments/sn4t2/how_does_one_get_rtl_as_source_in_gnu/
and I had zero luck whatsoever trying to get it to work. I did some
further
digging regarding what functions were available in osmosdr using
dir(osmosdr) in Python and got this:

[‘SwigPyIterator’, ‘SwigPyIterator_swigregister’, ‘_RTLD_GLOBAL’,
builtins’, ‘doc’, ‘file’, ‘name’, ‘package’,
path’, ‘_dlopenflags’, ‘device’, ‘device_find’,
‘device_swigregister’,
‘device_t’, ‘device_t_swigregister’, ‘devices_t’,
‘devices_t_swigregister’,
‘meta_range_t’, ‘meta_range_t_swigregister’, ‘osmosdr_sink_c_sptr’,
‘osmosdr_sink_c_sptr_swigregister’, ‘osmosdr_source_c_sptr’,
‘osmosdr_source_c_sptr_swigregister’, ‘osmosdr_swig’, ‘range_t’,
‘range_t_swigregister’, ‘range_vector_t’, ‘range_vector_t_swigregister’,
‘sink_c’, ‘source_c’, ‘string_string_dict_t’,
‘string_string_dict_t_swigregister’, ‘string_vector_t’,
‘string_vector_t_swigregister’, ‘sys’]

Oddly enough there was a function called source_c, but no function
called
source. When I make gr-osmosdr with cmake, these are the enabled and
disabled components:

– ######################################################
– # gr-osmosdr enabled components
– ######################################################
– * Python support
– * sysmocom OsmoSDR
– * IQ File Source
– * Osmocom RTLSDR
– * RTLSDR TCP Client
– * RFSPACE Receivers

– ######################################################
– # gr-osmosdr disabled components
– ######################################################
– * Osmocom IQ Imbalance Correction
– * FUNcube Dongle
– * FUNcube Dongle Pro+
– * Ettus USRP Devices
– * Osmocom MiriSDR
– * HackRF Jawbreaker
– * nuand bladeRF
– * AIRSPY Receiver

Is osmosdr.source() in one of the disabled components? If so, what
dependencies do I need to install to get that component to work? I
can’t
seem to find any straightforward information as to what dependencies I
need
to get all the components to work.

I’ve been working on this for the past week and I have had little luck,
so
any help will be greatly appreciated :slight_smile:


View this message in context:
http://gnuradio.4.n7.nabble.com/gr-osmosdr-No-RTL2832-Source-Block-tp46936.html
Sent from the GnuRadio mailing list archive at Nabble.com.

Hi,

osmosdr.source is the name in gnuradio 3.7.x version
osmosdr.source_c is the name in gnuradio 3.6.x version

Are you sure your application is compatible with gnuradio 3.6.x ?

Cheers,

Sylvain

Ah, that would make sense. I converted all references to osmosdr.source
into osmosdr.source_c and everything seems to work fine now.

Thanks heaps for your help! :slight_smile:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs