Gr-lte error

I am facing this error while during make of gr-lte(
OS : Ubuntu 12.04
GNU Radio ver :
GCC : 4.6.3

make -j5
Scanning dependencies of target pygen_apps_9a6dd
Scanning dependencies of target _lte_swig_swig_tag
Scanning dependencies of target pygen_python_fd902
Scanning dependencies of target _lte_swig_doc_tag
[  0%] [  4%] [  4%] Built target pygen_apps_9a6dd
Generating __init__.pyc, viterbi_vfvb.pyc, hier_freq_estimate_cc.pyc,
hier_sss_sync_cc.pyc, hier_pss_sync_cc.pyc, decode_bch_vfvb.pyc,
decode_pbch_vcvf.pyc, estimator_parameterizer_msg.pyc, utils.pyc,
[  7%] Building CXX object
[  9%] Generating __init__.pyo, viterbi_vfvb.pyo, 
hier_sss_sync_cc.pyo, hier_pss_sync_cc.pyo, decode_bch_vfvb.pyo,
decode_pbch_vcvf.pyo, estimator_parameterizer_msg.pyo, utils.pyo,
Building CXX object
[ 11%] Building CXX object
Linking CXX executable _lte_swig_swig_tag
Linking CXX executable _lte_swig_doc_tag
[ 14%] Building CXX object
[ 14%] Built target _lte_swig_swig_tag
[ 14%] Built target pygen_python_fd902
[ 14%] [ 16%] [ 19%] Built target _lte_swig_doc_tag
Building CXX object 
Scanning dependencies of target pygen_swig_07e0e
Building CXX object
[ 21%] Generating doxygen xml for lte_swig_doc docs
[ 23%] Generating lte_swig_doc.i
[ 26%] Building CXX object
[ 28%] Building CXX object
In file included from
*error: ‘std::sqrt’ cannot appear in a constant-expression[ 30%] *
*error: a function call cannot appear in a constant-expression*
*error: ISO C++ forbids initialization of member ‘d_SQRT2’ 
*error: making ‘d_SQRT2’ static [-fpermissive]*
Generating lte_swig.tag
[ 33%] Swig source
make[2]: *** 
Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [lib/CMakeFiles/gnuradio-lte.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 38%] [ 38%] Generating lte_swig.pyo
Generating lte_swig.pyc
[ 38%] Built target pygen_swig_07e0e
make: *** [all] Error 2

My Solution : I went to line 49 of file lte_qpsk_soft_demod_vcvf.h,
the declaration of float d_SQRT2 and its initialization i.e.
and made it a global declaration. And it worked for me as I am able to
lte block in grc.

Is this patch wrong ! Somehow I am having doubt over it

View this message in context:
Sent from the GnuRadio mailing list archive at


this is a C++11 feature you just “discovered”. Older compilers won’t
you to compile this code like this. Although they usually through a
that this is C++11 code. I don’t know which commit it was, but I removed
this expression and put in some pre-C++11 code instead.
Also I recommend upgrading to GR 3.7 and the gr-lte blocks which use the
3.7 API. All bugfixes and new features go in there.

Another smaller solution to the problem should be to make this member
static. This should be allowed by older compilers.

Happy hacking

On Thu, Jan 9, 2014 at 3:08 PM, sumitstop

static also not working. Throwing same error.
I downloaded from here

Also one strange thing. When I drag the first block named block_tests
…nothing happens ! … Just a blank palette of grc comes…
I think I shall grab 3.7

View this message in context:
Sent from the GnuRadio mailing list archive at

Thanks for the feedback. I’ll probably add a warning in the README.
Interesting that this block ‘block_tests’ shows up. It was never meant
show up in GRC and I thought I removed it.
During the transition to the GR 3.7 API a lot of code clean up happened
well. So this should be cleaned up by now.

On Thu, Jan 9, 2014 at 3:57 PM, sumitstop