Gr-ctrlport

I am building GNU Radio 3.7.3 from source and wish to
enable the CTRLPORT module. I have already installed
Ice-3.5.1 for C++ in the location /opt/Ice-3.5.1
(satisfying required dependencies)
My current gcc version is 4.8.1
But, cmake is not able to locate ice 3.5.1 and hence disables support
for gr-ctrlport.
I tried by passing the flags, -DICE_MANUALL_INSTALL_PATH=/opt/Ice-2.5.1/
and -DENABLE_GR_CTRLPORT=ON, but to no avail. Any suggestions ?

Here is the relevant cmake output :


– Python checking for Ice >= 3.5
– Python checking for Ice >= 3.5 - not found
– ICE 3.5 not found. Looking for 3.4
– package ‘Ice-3.4’ not found

– Configuring gr-ctrlport support…
– Dependency Boost_FOUND = TRUE
– Dependency SWIG_FOUND = TRUE
– Dependency SWIG_VERSION_CHECK = TRUE
– Dependency ICE_FOUND =
– Dependency ENABLE_GNURADIO_RUNTIME = ON
– Disabling gr-ctrlport support.
– Override with -DENABLE_GR_CTRLPORT=ON/OFF

I couldn’t build python extensions for ice 3.5.1 on ubuntu 12.04
(something
wrong with the tarball available for download). Has anyone got this to
work
correctly ?
Else, do I have to revert to ice 3.4.x with something less than gcc-4.6
?

Abhishek

On Wed, Mar 12, 2014 at 7:12 AM, Abhishek B.
[email protected] wrote:

Here is the relevant cmake output :
– Dependency SWIG_VERSION_CHECK = TRUE

Abhishek

Python needs to know where the Ice module is and be able to run it,
which means your system needs to know where libIce.so is. In other
words, you need to set your PYTHONPATH to include
/opt/Ice-3.5.1/python and LD_LIBRARY_PATH to include
/opt/Ice-3.5.1/lib.

Tom

Paths were already updated. So that’s not the issue I feel.
I will retry using the build-gnuradio script to ensure nothing was wrong
with downloaded tarball.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs