Gr-audio selecting jack automatically over ALSA?

Hi Folks,

Finally got around to compiling the latest git version of gnuradio,
(well from August 4th), so I can try out my new FunCube dongle.

Got it all compiled and configured to my satisfaction. Was surprised
to see it try and start jackd when I fired up Alex’s FCD sample
application.

I was about to blame Alex for not handling the case where jack is
present correctly, but double checked by just using an audio source,
and sure enough, it attempted again to fire up jack…

So I dug around, and found the audio_module = option in the config
file, and changed it from auto, to alsa. Same thing happened…

Triple checked with an strace of the companion that it did actually
read the file I thought it did, and yes, it did.

Anyone know of another way for me to (temporarily) force it to use
pure ALSA rather than jack (I actually don’t want jack permanently
disabled, as I do use it when doing audio stuff)

Or have I missed something obvious ?

Best Regards

Iain

On Sun, Aug 7, 2011 at 2:03 PM, Iain Young, G7III [email protected]
wrote:

present correctly, but double checked by just using an audio source,
and sure enough, it attempted again to fire up jack…

So I dug around, and found the audio_module = option in the config
file, and changed it from auto, to alsa. Same thing happened…

Triple checked with an strace of the companion that it did actually
read the file I thought it did, and yes, it did.

Hi Iain,

There is a known issue with the preferences mechanisms, but that is
only applicable for C++ applications:
http://gnuradio.org/redmine/issues/421

So if you can not select alsa when using python or gnuradio-companion,
then you do not have alsa support installed. This would also be
consistent with my experience that alsa takes precedence over jack.

I think the only way to find out whether you have alsa support is to
look in the config.log. I have this:
GR_AUDIO_ALSA_SUPPORT_FALSE=’#’
GR_AUDIO_ALSA_SUPPORT_TRUE=’’
GR_AUDIO_JACK_SUPPORT_FALSE=’#’
GR_AUDIO_JACK_SUPPORT_TRUE=’’
GR_AUDIO_OSS_SUPPORT_FALSE=’#’
GR_AUDIO_OSS_SUPPORT_TRUE=’’
GR_AUDIO_OSX_SUPPORT_FALSE=’’
GR_AUDIO_OSX_SUPPORT_TRUE=’#’
GR_AUDIO_PORTAUDIO_SUPPORT_FALSE=’#’
GR_AUDIO_PORTAUDIO_SUPPORT_TRUE=’’
GR_AUDIO_WINDOWS_SUPPORT_FALSE=’’
GR_AUDIO_WINDOWS_SUPPORT_TRUE=’#’

which I assume means that I have jack, alsa and oss support. I don’t
know if there is a better way to check that. You can of course also
check if you have the files:
gr-audio/lib/audio_alsa_source.lo
gr-audio/lib/audio_alsa_sink.lo

There used to be a listing of which audio backends are going to be
built at the end of the configure step. It would be nice to get that
back simply because audio on linux is such a horrible mess.

Anyone know of another way for me to (temporarily) force it to use
pure ALSA rather than jack (I actually don’t want jack permanently
disabled, as I do use it when doing audio stuff)

Yes, but try first to see if you actually have alsa support installed

Alex