Gr-ais UHD Source adress error

I am trying to run gr-ais and feel like i am getting really close. I am
fairly new to linux and can not find the source adress for my UHD, which
is a SDR USB Dongel. I run lsusb and get

[email protected] ~/Desktop/gr-ais/apps $ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 0ccd:00d7 TerraTec Electronic GmbH

How would i go about finding the source adress? thanks

UPDATE: It seems to me that OsmoSDR is needed because i dont have a
USRP only a SDR dongle. It seems Nick took out the OsmoSDR part when he
made it a cmake not bootstrap.

so i got nowhere with installing OsmoSDR, I instead found the older
version with the osmosdr built in. It has the -d and -D options which
are missing from the newer version. When i enter:

ais_rx.py --rate 1024e3 --gain 30 --error -110 -d -D rtl=0

i just get the help menu popping up…still stuck

Can it be because the rtl_sdr is not set to be run by non-root accounts?
Even though when i run ais_rx.py i use sudo? Re-installing OsmoSDR with
appropriate udev rules. Any help?

well, im done for today. I installed this one because i thought it
would work better https://github.com/chgans/gr-ais
and now when i run it i get the following errors:

[email protected] ~ $ ais_rx.py --rate 96e3 --error -100 -d -D rtl=0 --gain
30
linux; GNU C++ version 4.6.3; Boost_104900; UHD_003.004.002-0-unknown

gr-osmosdr supported device types: file rtl_tcp uhd

FATAL: No supported devices found to pick from.

Trying to fill up 1 missing channel(s) with gaussian noise.
This is being done to prevent the application from crashing
due to a gnuradio bug. The maintainers have been informed.

Failed to set frequency
A: Sampling @ 96000.000000, decim @ 1

I am completely stumped and my brain hurts. rtl_tcp work just fine and
all the other rtl tools. IDK, thanks in advance.

that did it! i copied the rtl_sdr rules file to the udev/ directory and
then got a usb_claim_interface error -6 error. Figured it was just the
tcp server i was running earlier not releasing the USB dongle. Rebooted
and it is working like a champ. Overall I wish nick didnt take out the
-d and -D configuration in his newest build. That took me the longest
time to overcome(and really just gave up and went to a different build)
or atleast had nstructions on how to interface OSMOSDR with it. Still
can’t figure that out, but found the older build and everything seems to
be working. Hope this log helps someone else.