Gr-air-modes compilation

I am trying to compile the lasted code from github and am getting an
error
from CMake. It is looking for pyZMQ and not finding it. I tried to
install
the module but not having much luck - that is it is not simple. Is
there a
scenario that I can follow? The dependency list does not cite PyMZQ so
I am
curious if it really needs it. This is on Ubutunu 14.04.

Alan - W6ARH

I got it complied and working. The key was to install Cython. It is
probably worthwhile to add it to the dependency list.

Alan

From: Nick F. [mailto:[email protected]]
Sent: Sunday, April 27, 2014 4:30 PM
To: Silverfox
Subject: Re: [Discuss-gnuradio] gr-air-modes compilation

Open python, type “import zmq”. What’s the result?

On Sun, Apr 27, 2014 at 4:24 PM, Silverfox [email protected]
wrote:

I am trying to compile the lasted code from github and am getting an
error from CMake. It is looking for pyZMQ and not finding it. I tried
to install the module but not having much luck - that is it is not
simple. Is there a scenario that I can follow? The dependency list
does not cite PyMZQ so I am curious if it really needs it. This is on
Ubutunu 14.04.

Alan - W6ARH

That’s very strange. Cython isn’t required for either PyZMQ or
gr-air-modes. My guess is you have multiple Python versions installed,
and
PyZMQ got installed to a version that isn’t the one gr-air-modes found.

Whatever works! =)

–n

gr-air-modes did not require it but it was needed to compile libzmq.
I’ll check but I am sure all I have is Python 2.7.

Cheers,

Alan

From: Nick F. [mailto:[email protected]]
Sent: Monday, April 28, 2014 9:13 AM
To: Silverfox
Cc: GNURadio D.ion List
Subject: Re: [Discuss-gnuradio] gr-air-modes compilation

That’s very strange. Cython isn’t required for either PyZMQ or
gr-air-modes. My guess is you have multiple Python versions installed,
and PyZMQ got installed to a version that isn’t the one gr-air-modes
found.

Whatever works! =)

–n

On Mon, Apr 28, 2014 at 9:10 AM, Silverfox [email protected]
wrote:

I got it complied and working. The key was to install Cython. It is
probably worthwhile to add it to the dependency list.

Alan

From: Nick F. [mailto:[email protected]]
Sent: Sunday, April 27, 2014 4:30 PM
To: Silverfox
Subject: Re: [Discuss-gnuradio] gr-air-modes compilation

Open python, type “import zmq”. What’s the result?

On Sun, Apr 27, 2014 at 4:24 PM, Silverfox [email protected]
wrote:

I am trying to compile the lasted code from github and am getting an
error from CMake. It is looking for pyZMQ and not finding it. I tried
to install the module but not having much luck - that is it is not
simple. Is there a scenario that I can follow? The dependency list
does not cite PyMZQ so I am curious if it really needs it. This is on
Ubutunu 14.04.

Alan - W6ARH

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs