Gr 3.5.1 & osx

Has anyone built 3.5.1 release and UHD 3.3.2 on OSX 10.6 (Snow Leopard)
yet?

@(^.^)@ Ed

Sent from my iPod

Hi Ed - I build from their respective GIT masters, not from those
specific releases; but, yes, they seem to work for me. I use CMake for
both, since (1) GNU autotools is on the way out; and (2) it works better
(e.g., I don’t have to disable Volk). - MLD

On Mar 2, 2012, at 9:39 AM, Arturo R. wrote:

can i build the master git branch on macos X 10.7.3 with cmake ? have i to
satisfy the build pre-requisites with macports as usual ?

Hi Arturo - I believe that if you use MacPorts to install the background
dependencies – just do “sudo port install gnuradio”, and then, hours
later, you can remove the installed GNU Radio / usrp ports, if any
actually got installed. You’ll need to install CMake too, since the
current GR ports still use GNU Autotools. You should then be able to
use CMake to build GNU Radio from the GIT master on OSX 10.7.3. I’m
still using 10.6.8, but I know others who’ve used 10.7 and had success.
Getting the dependencies to install is the tricky part, as always :slight_smile:
Give it a whirl, good luck, and please do let me/the list know if you
have issues. - MLD

Nella citazione in data mer 11 gen 2012 20:28:43 CET, Michael D.
ha scritto:

can i build the master git branch on macos X 10.7.3 with cmake ? have i
to satisfy the build pre-requisites with macports as usual ?

Nella citazione in data ven 02 mar 2012 15:45:45 CET, Michael D.
ha scritto:

ok i’ll try to satisfy the dependencies and build with cmake :D. wish
me luck…

Hi guys,

On OSX 10.6.8 I did the following:

$ git clone git://code.ettus.com/ettus/uhd.git
$ cd uhd
$ mkdir build
$ cd build
$ cmake …/
$ make
$ sudo make install
$ cd…
$ git clone git://gnuradio.org/gnuradio
$ cd gnuradio
$ mkdir build
$ cd build cmake …/


– ######################################################
– # Gnuradio enabled components
– ######################################################
– * python-support
– * testing-support
– * volk
– * doxygen
– * gruel
– * gnuradio-core
– * gr-atsc
– * gr-audio
– * gr-digital
– * gr-noaa
– * gr-pager
– * gr-qtgui
– * gr-trellis
– * gr-uhd
– * gr-utils
– * gr-video-sdl
– * gr-vocoder

– ######################################################
– # Gnuradio disabled components
– ######################################################
– * gnuradio-companion
– * gr-comedi
– * gr-shd
– * gr-wxgui

– Using install prefix: /usr/local
– Building for version: v3.5.1-196-g4f0add17 / 3.5.2git
– Configuring done
– Generating done

$ make
$ sudo make install

It seems that worked! :slight_smile:

Best regards,
Carles

Hi Carles - That’s great to hear! I take it that you don’t have WX
installed? Using the QtGui really is nicer anyway :slight_smile: But, having
gnuradio-companion is also nice … maybe there is some other dependency
that isn’t getting met for GRC? - MLD

On Sun, Mar 4, 2012 at 12:22 AM, Michael D. [email protected]
wrote:

Hi Carles - That’s great to hear! I take it that you don’t have WX installed?
Using the QtGui really is nicer anyway :slight_smile: But, having gnuradio-companion is also
nice … maybe there is some other dependency that isn’t getting met for GRC? -
MLD

Yes:

$ cmake …/


– Python checking for pygtk >= 2.10.0
– Python checking for pygtk >= 2.10.0 - not found

– Configuring gnuradio-companion support…
– Dependency ENABLE_GR_CORE = ON
– Dependency ENABLE_PYTHON = ON
– Dependency PYTHON_MIN_VER_FOUND = TRUE
– Dependency CHEETAH_FOUND = TRUE
– Dependency LXML_FOUND = TRUE
– Dependency PYGTK_FOUND = FALSE
– Dependency NUMPY_FOUND = TRUE
– Disabling gnuradio-companion support.
– Override with -DENABLE_GRC=ON/OFF

Does anybody know how to install pygtk in Mac OS? I’d love to use
gnuradio-companion…

Best regards,
Carles

Did you use MacPorts for the background dependencies? If so, you can
install one of the py*-pygtk, e.g., “sudo port install py27-gtk” for
Python 2.7 (which is what I use). I find that on OSX, Python 2.6 play
nice with GNU Radio or GRC, but 2.7 does; YMMV. - MLD

On Mar 3, 2012, at 8:40 PM, Michael D. wrote:

I find that on OSX, Python 2.6 play nice with GNU Radio or GRC, but 2.7 does;

meant: “Python 2.6 does not play nice” …

Hmm … not sure what’s going on. When you’re in Python, can you do
“import gtk” successfully? That’s what CMake is testing for, roughly.
If it can’t, hopefully the error will shed some light as to what’s going
on. - MLD

Thanks for the hint. It seems that there is a problem with the
libfreetype library:

$ python
Python 2.7.2 (default, Jan 21 2012, 15:35:05)
[GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin
Type “help”, “copyright”, “credits” or “license” for more information.

import gtk
Traceback (most recent call last):
File “”, line 1, in
File
“/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/gtk-2.0/gtk/init.py”,
line 40, in
from gtk import _gtk
ImportError:
dlopen(/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/gtk-2.0/gtk/_gtk.so,
2): Library not loaded: /opt/local/lib/libfreetype.6.dylib
Referenced from:
/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/gtk-2.0/gtk/_gtk.so
Reason: Incompatible library version: _gtk.so requires version
15.0.0 or later, but libfreetype.6.dylib provides version 14.0.0

I will try to fix this. I will post the solution in case of success,
maybe can be useful to others.

Best regards,
Carles

It looks like you have a mixed install, somehow, of MacPorts stuff; some
older, some newer. If you haven’t done it recently, I’d recommend:

sudo port selfupdate
sudo port upgrade outdated

and, if that breaks, do:

sudo port clean outdated
sudo port -p upgrade outdated

and then report the issues on a MP ticket if a search on active tickets
turns up nothing. My guess is that doing the above will fit the issue.

  • MLD

Il 04/03/12 00:18, Carles Fernandez ha scritto:

$ make
– ######################################################
– * gr-pager
– * gnuradio-companion
$ make


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

I think i’ve sorted out the dependencies for building gnuradio on Lion
10.7.3

/sudo port install boost icu cppunit fftw-3-single gawk
readline gsl texinfo guile python27 py27-numpy py27-nose py27-distribute

libsndfile portaudio py27-opengl py27-opengl-accelerate py27-pil lcms
py27-tkinter
py27-wxpython wxWidgets mesa makedepend xorg-dri2proto xorg-glproto
xorg-libXmu
py27-cheetah py27-gtk libglade2 py27-cairo py27-py py27-gobject
py27-lxml doxygen
libusb-legacy sdcc29 gputils py27-pyqt4 py27-sip py27-pyqwt qt4-mac dbus
libmng qt4-mac qwtplot3d qwt52 libsdl/

However :

*First *
/py27-wxpython/ doesn’t install on macports. I’ll post it on the
macports mailing list then we aren’t able to use the wxgui module

Second
by using autotools with /

./configure LDFLAGS="-L/opt/local/lib" CPPFLAGS="-I/opt/local/include"
CC=clang --disable-gr-qtgui --disable-docs/

builds the latest tarball (3.5.2.1) and i need some help for the
DYLD_LIBRARY_PATH because gnuradio-companion start with an error
message though PYTHONPATH is correctly set

Third
downloaded the git version and after the usual steps with cmake, the
building crashes at the 3% with the error

/cc1: error: unrecognized command line option “-mpopcnt”
make[2]: *** [volk/lib/CMakeFiles/volk.dir/volk_machine_sse4_a_64.c.o]
Error 1
make[1]: *** [volk/lib/CMakeFiles/volk.dir/all] Error 2
make: *** [all] Error 2/

any suggest for all the three scenarios ?

Best Regards,

          Arturo R.

Well, actually I had the gnuradio port already and I did a “sudo port
uninstall gnuradio” before all the building process. I saw that I have
py27-gtk installed but python version is 2.6.7…so I did:

$ sudo port select python python27
$ python -V
Python 2.7.2

but when I do

$ cmake …/

I stiil get

– Configuring gnuradio-companion support…
– Dependency ENABLE_GR_CORE = ON
– Dependency ENABLE_PYTHON = ON
– Dependency PYTHON_MIN_VER_FOUND = TRUE
– Dependency CHEETAH_FOUND = TRUE
– Dependency LXML_FOUND = TRUE
– Dependency PYGTK_FOUND = FALSE
– Dependency NUMPY_FOUND = TRUE
– Disabling gnuradio-companion support.

Is there any step I’m missing?

Thanks,
Carles

Thanks,
Carles

Nella citazione in data Thu Mar 22 15:17:03 2012, Michael D. ha
scritto:

Yeah; I’d believe that. Nothing like a “few” background dependencies as added
by MacPorts to those top-level ones. I tried creating a stand-alone .app for GRC,
and it turned out to be something like 600 MB when all of these dependencies were
included. Many of them are spurious – not directly relevant – but include as
options or whatever. MP folks have had a discussion about this issue recently,
since it’s a real problem.

make[2]: *** [volk/lib/CMakeFiles/volk.dir/volk_machine_sse4_a_64.c.o] Error 1
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

ok i’ll do other “experiments” and report news…thx very much :smiley:

Nella citazione in data Thu Mar 22 23:43:29 2012, Arturo R. ha
scritto:

lcms py27-tkinter
MB when all of these dependencies were included. Many of them are
There’s are a few discussions about py27-wxpython on various MP lists

PATH and PYTHONPATH should be sufficient.

[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

ok i’ll do other “experiments” and report news…thx very much :smiley:

downloaded the latest git version and made a little progress in the
third case. I set :

export CXX=clang++
export CC=clang

and the cmake building worked ! ! !. Now i have to set the python path
correctly. GRC still doesn’t run but the python interpreter import the
gnuradio module correctly.

i removed the documentantion from building because it seems to stuck at
a certain point, and cpu(s) load is at full ! ! !

The py27-wxpython issue still remains, i’ll post a ticket on macports

Regards, Arturo

On Mar 22, 2012, at 9:55 AM, Arturo R. wrote:

I think i’ve sorted out the dependencies for building gnuradio on Lion 10.7.3

sudo port install boost icu cppunit fftw-3-single gawk
readline gsl texinfo guile python27 py27-numpy py27-nose py27-distribute
libsndfile portaudio py27-opengl py27-opengl-accelerate py27-pil lcms
py27-tkinter
py27-wxpython wxWidgets mesa makedepend xorg-dri2proto xorg-glproto xorg-libXmu

py27-cheetah py27-gtk libglade2 py27-cairo py27-py py27-gobject py27-lxml
doxygen
libusb-legacy sdcc29 gputils py27-pyqt4 py27-sip py27-pyqwt qt4-mac dbus libmng
qt4-mac qwtplot3d qwt52 libsdl

Yeah; I’d believe that. Nothing like a “few” background dependencies as
added by MacPorts to those top-level ones. I tried creating a
stand-alone .app for GRC, and it turned out to be something like 600 MB
when all of these dependencies were included. Many of them are spurious
– not directly relevant – but include as options or whatever. MP
folks have had a discussion about this issue recently, since it’s a real
problem.

However :

First
py27-wxpython doesn’t install on macports. I’ll post it on the macports mailing
list then we aren’t able to use the wxgui module

There’s are a few discussions about py27-wxpython on various MP lists
right now. Seems like maybe you’re not alone. Please do search for a
ticket for: < https://trac.macports.org/search >. I have no issue with
this port on 10.6.8, and it works correctly with 64-bit Wx!

Second
by using autotools with

./configure LDFLAGS="-L/opt/local/lib" CPPFLAGS="-I/opt/local/include" CC=clang
–disable-gr-qtgui --disable-docs

builds the latest tarball (3.5.2.1) and i need some help for the
DYLD_LIBRARY_PATH because gnuradio-companion start with an error message though
PYTHONPATH is correctly set

You should be able to compile GR without LDFLAGS or CPPFLAGS, if you’ve
set the PKG_CONFIG_PATH to include “/opt/local/lib/pkgconfig”. You’ll
probably want to set CXX to clang++ (or, whatever that is called) along
with CC; I don’t think CC is actually used, but it can’t hurt to set it.
Once installed, you should be able to execute GR scripts and GRC without
resorting to the DYLD_LIBRARY_PATH – the PATH and PYTHONPATH should be
sufficient.

Third
downloaded the git version and after the usual steps with cmake, the building
crashes at the 3% with the error

cc1: error: unrecognized command line option “-mpopcnt”
make[2]: *** [volk/lib/CMakeFiles/volk.dir/volk_machine_sse4_a_64.c.o] Error 1
make[1]: *** [volk/lib/CMakeFiles/volk.dir/all] Error 2
make: *** [all] Error 2

No idea, but using CMake is the way to go to get Volk working. Could be
an OSX 10.7 issue; I’m still using 10.6 though I do do testing using an
OSX 10.7 boot disk. I haven’t tried this in a while, so I’ll give it a
whirl later today or tomorrow, as time allows.

Good luck! - MLD

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs