Gnuradio with wxpython


#1

Hi list,

I’m trying to build wxPython (2.8.9.2) from source.

I read two manuals to install wxpython:

I have configured PYTHONPATH.
Python version 2.5.4

Is there problem with gnuradio + wxpython?

[ERROR] ====================================================
Component gr-video-sdl passed configuration checks; building.
Traceback (most recent call last):
File “”, line 1, in
File
“/home/gnuradio/workspace/src/wxPython-src-2.8.9.2/wxPython/wx/init.py”,
line 45, in
from wx._core import *
File
“/home/gnuradio/workspace/src/wxPython-src-2.8.9.2/wxPython/wx/_core.py”,
line 4, in
import core
ImportError: No module named core
configure: error: Component gr-wxgui has errors; stopping.
[ERROR] ====================================================


#2

On Tue, Mar 24, 2009 at 08:45:19AM -0300, Paulo B. wrote:

File
“/home/gnuradio/workspace/src/wxPython-src-2.8.9.2/wxPython/wx/_core.py”,
line 4, in
import core
ImportError: No module named core
configure: error: Component gr-wxgui has errors; stopping.
[ERROR] ====================================================

It looks like there’s a problem with your wxPython installation.

Why are you installing wxPython from source? Have you tried
installing the prepackaged binaries?

Eric


#3

i need to install from source, because i don’t have permission apt. I
think
that my installation of wxpython it’s right! I will try again, thanks!

2009/3/24 Eric B. removed_email_address@domain.invalid