Gnuradio/usrp on MacOSX Darwin 8.5


#1

There are several documents out and about on how to get Gnuradio built
and running on MacOSX.

I found it quite a bit easier than some of these documents indicated. I
was able to get Python 2.4.3 automatically installed. WxPython
automatically installed. Both of these were from dmg packages available
for download from the Python and wxPython sites respectively. The nice
thing about the wxPython dmg is that it contains a prebuilt wxwidgets
for OSX.

Portaudio was downloaded using the new svn download

svn co https://www.portaudio.com/repos/portaudio/branches/v19-devel

./configure;make; sudo make install

was done and it just plain comes up and works. PERIOD, end of story.

darwinports is absolutely imperative

http://darwinports.opendarwin.org/

I installed gcc-4.1.0, and the usual Numeric, libusb, etc. from the
build_install list at

http://www.kd7lmo.net/ground_gnuradio_install.html

using darwinports.

I did

./for_all_dirs …/buildit

and then entire thing (with the exception of the “for tars only” bug I
talked about in an earlier message) just plain built.

I went to

~/gr-build/gnuradio-examples/python/audio

and edited multi_tone.py and changed

from gnuradio import audio

to

from gnuradio import audio_portaudio

down further in the file I changed

dst = audio.sink (sample_rate,

to

dst = audio_portaudio.sink (sample_rate,

and it ran with the usual tones.

Then I did the same changes in

gnuradio-example/python/usrp/usrp_wfm_rcv_pll.py

I did ./usrp_wfm_rcv_pll.py -f 93.3 -V -4

and WMMR came out of the speakers and the display was as the attached.

It all just worked.

Because of the lack of use of altivec, it consumes one of the
processors to 90% in my dual G5 doing the receiver and display. This is
not a low overhead application.

Bob


#2

I just tried to compile the latest portaudio (v19-devel) under Darwin
8.6 (OSX 10.4.6), and I couldn’t get it to link correctly (there were
also some serious looking warnings in the compile at which I would
look carefully if I were programming that code). The link complains
that:

“ld: common symbols not allowed with MH_DYLIB output format with the -
multi_module option
pa_unix/pa_unix_util.o definition of common _paUnixMainThread (size 4)
/usr/bin/libtool: internal link edit command failed”

when trying to create the DYLIB (“paUnixMainThread” is a global
variable). It’s trying to use Apple’s libtool, which might make a
difference. But I can’t quickly see a way to change that (e.g. “make
LIBTOOL=xxx”). Maybe it’s just the currently checked in version
which is failing; so I’ll wait a few days and try it again.

Anyone else have this issue? If not - using the current SVN archive
(says revision 992; as of 25-Apr-2006 @ 6:45 PM EDT) - then maybe my
shell environment is messed up … but I’ve been very careful about
that to make sure GNURadio and all its dependencies compile and
install correctly. - MLD