GNURadio compile notes for Debian Lenny (Testing)

Hello,

I am looking into switching from SuSE to Debian so I am “testing” Debian
Etch and Lenny these past months on several new systems. SuSE seems too
bloated and I rather have more control over what is loaded on the
computer. APT seems better than RPM.

I was able to compile GNURadio on Debian Lenny. Here are some rough
notes as to the packages needed to compile GNURadio with ALSA and USRP
support. I used a recent GNURadio version from the subversion
repository trunk.

I am still configuring and testing the system so the General packages
are incomplete. They represent packages that may be needed for GNURadio
and were installed either directly or indirectly through dependencies of
other general packages I installed.

General Environment (incomplete list)
python (Lenny default is Version 2.5. Version 2.4 is available.)
libsdl1.2debian (was installed as part of mplayer)

General Build Environment (incomplete list)
gcc (Lenny default is Version 4.3. Version 4.1 and 4.2 are available.)
make
make-doc
autoconf
build-essential
subversion
subversion-tools
kdesvn (KDE Wrapper for Subversion)

General Development Packages (incomplete list)
xorg-dev

GNURadio Development Packages
libfftw3-dev
libboost1.35-dev
libcppunit-dev
libasound-dev
swig
guile-1.8-dev
libsdl1.2-dev
libusb-dev
python2.5-dev
python-numpy
python-wxgtk2.8
sdcc-nf (USRP needs the non-free version)

73 Eric

Eric C. wrote:

I was able to compile GNURadio on Debian Lenny. Here are some rough
notes as to the packages needed to compile GNURadio with ALSA and
USRP support. I used a recent GNURadio version from the subversion
repository trunk.

Just FYI–the Ubuntu binary packages for GNU Radio 3.1.3 hosted at
gnuradio.org could be made to work with Debian Lenny with very few
changes.

I’d produce them here, but lack the infrastructure to do the build and
test. They have been built on Etch in the past with no issues.

The Debian package machinery in the trunk is fairly out of date, and
needs to be updated. This is a task for release 3.2. I’ll do this for
Ubuntu, but it would be welcomed if someone would volunteer to test and
produce the Debian Lenny packages. The needed repository infrastructure
is already on gnuradio.org, but has no packages in it.

Here is an (outdated) script in the trunk that installs the build
dependencies:

http://gnuradio.org/trac/browser/gnuradio/trunk/debian/install-build-deps.sh

(It lacks new requirements for grc, for example, and the required boost
version.)

Anyway, if you or anyone else is interested in helping here, it would be
a useful way to contribute to the project.

Johnathan C. wrote:

gnuradio.org could be made to work with Debian Lenny with very few changes.
Here is an (outdated) script in the trunk that installs the build

Hello,

I will be willing to help when I get setup and comfortable with the
debian build system.

I noticed gnuradio included in the debian archive but it is for one of
the older releases of debian.

Sometimes I wonder if I should use kbuntu instead of debian but I
consider kbuntu and ubuntu more as live cd distributions.

73 Eric

On Tue, 2009-01-13 at 20:41 +0100, Markus F. wrote:

I installed anything in Debian Lenny which contains wx.

It needs python-wxgtk2.8, is this installed?

-Johnathan

I tried to the stable release of gnuradio,
version 3.1.3, but without success.

./configure --enable-gr-wxgui --enable-grc --enable-usrp
–enable-gr-usrp --enable-gr-audio-alsa --enable-gnuradio-examples
–enable-gnuradio-core --enable-gr-audio-oss

Ther error message is:
Traceback (most recent call last):
File “”, line 1, in
ImportError: No module named wx
configure: error: Component gr-wxgui has errors; stopping.

I installed anything in Debian Lenny which contains wx.
Any Idea ?

Regards Markus

Johnathan C. schrieb:

On Tue, 2009-01-13 at 20:41 +0100, Markus F. wrote:

I installed anything in Debian Lenny which contains wx.

It needs python-wxgtk2.8, is this installed?

-Johnathan
I think so. These packages are installed
which contains <wx>:

libwxbase2.6-0
libwxbase2.6-dev
libwxbase2.8-0
libwxbase2.8-0-ansi
libwxbase2.8-ansi-dev
libwxbase2.8-dev
libwxgtk2.6-0
libwxgtk2.6-dev
libwxgtk2.8-0
libwxgtk2.8-0-ansi
libwxgtk2.8-ansi-dev
libwxgtk2.8-dev
python-wxgtk2.8
python-wxversion
wx-common
wx2.6-headers
wx2.6-i18n
wx2.8-headers

Regards Markus

On Tue, 2009-01-13 at 22:39 +0100, Markus F. wrote:

It needs python-wxgtk2.8, is this installed?

-Johnathan
I think so. These packages are installed
which contains <wx>:

Can you try manually importing the package?

$ python

import wx

This may be the import issue Eric mentioned with Python 2.6.

-Johnathan

Johnathan C. schrieb:

Can you try manually importing the package?

$ python

import wx

This may be the import issue Eric mentioned with Python 2.6.
I tried to,
import wx
with eric and in the shell.
The same error.
It is python 2.5.2 not 2.6.x version.
I am not sure if this is important.

Regards Markus

On Tue, 2009-01-13 at 22:59 +0100, Markus F. wrote:

It is python 2.5.2 not 2.6.x version.
I am not sure if this is important.

If you cannot manually run Python and import the ‘wx’ module, then this
is not a GNU Radio problem, but some system problem related to your
Python installation.

-Johnathan

On Tue, 2009-01-13 at 23:16 +0100, Markus F. wrote:

Hmm you are right.

I searched for a file <wx.*>, but doesn’t find anything except
this:
/usr/share/bakefile/presets/wx.bkl
/usr/include/wx-2.8/wx/wx.h
/usr/lib/wx/python/wx.pth
/var/lib/dpkg/alternatives/wx.pth
/etc/alternatives/wx.pth

I’m sorry, I can’t help you any further with this. Perhaps someone
familiar with Debian testing can work with you off the list to get your
Python set up fixed.

-Johnathan

Johnathan C. schrieb:

The same error.
It is python 2.5.2 not 2.6.x version.
I am not sure if this is important.

If you cannot manually run Python and import the ‘wx’ module, then this
is not a GNU Radio problem, but some system problem related to your
Python installation.
Hmm you are right.

I searched for a file <wx.*>, but doesn’t find anything except
this:
/usr/share/bakefile/presets/wx.bkl
/usr/include/wx-2.8/wx/wx.h
/usr/lib/wx/python/wx.pth
/var/lib/dpkg/alternatives/wx.pth
/etc/alternatives/wx.pth

I also searched online at the debian archiv.
http://packages.debian.org/search?searchon=contents&keywords=wx&mode=filename&suite=testing&arch=i386

There is no file named <wx.py> on my system ?

Is there a <wx.py> file on your system ?

Or should be the <wx.h> file imported ?

Regards Markus

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs