Gnuradio 3.4.1 build error

Hello,

I am trying to build gnuradio 3.4.1 on ubuntu for usrp1 but it gives me
the
following error when I run the make command. Please help!

/home/imran/Desktop/gnuradio/gnuradio-3.4.1/gnuradio-core/
src/lib/.libs/libgnuradio-core.so: undefined reference to
boost::filesystem3::detail::create_directory(boost::filesystem3::path const&, boost::system::error_code*)' /home/imran/Desktop/gnuradio/gnuradio-3.4.1/gnuradio-core/ src/lib/.libs/libgnuradio-core.so: undefined reference toboost::filesystem3::path::operator/=(boost::filesystem3::path const&)’
/home/imran/Desktop/gnuradio/gnuradio-3.4.1/gnuradio-core/
src/lib/.libs/libgnuradio-core.so: undefined reference to
boost::system::system_category()' /home/imran/Desktop/gnuradio/gnuradio-3.4.1/gnuradio-core/ src/lib/.libs/libgnuradio-core.so: undefined reference toboost::filesystem3::detail::status(boost::filesystem3::path const&,
boost::system::error_code*)’
/home/imran/Desktop/gnuradio/gnuradio-3.4.1/gnuradio-core/
src/lib/.libs/libgnuradio-core.so: undefined reference to
boost::filesystem3::path::wchar_t_codecvt_facet()' /home/imran/Desktop/gnuradio/gnuradio-3.4.1/gnuradio-core/ src/lib/.libs/libgnuradio-core.so: undefined reference toboost::system::generic_category()’
collect2: ld returned 1 exit status
make[5]: *** [usrp_rx_cfile] Error 1
make[5]: Leaving directory /home/imran/Desktop/gnuradio/ gnuradio-3.4.1/gr-usrp/apps' make[4]: *** [all] Error 2 make[4]: Leaving directory/home/imran/Desktop/gnuradio/
gnuradio-3.4.1/gr-usrp/apps’
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory /home/imran/Desktop/gnuradio/ gnuradio-3.4.1/gr-usrp' make[2]: *** [all] Error 2 make[2]: Leaving directory/home/imran/Desktop/gnuradio/
gnuradio-3.4.1/gr-usrp’
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/imran/Desktop/gnuradio/gnuradio-3.4.1’
make: *** [all] Error 2

Use a different version of boost for the older Gnuradio builds, I used
boost-1.40 to compile 3.4.0 against which worked.

I tried with boost-1.37 and boost-1.40 but its giving me error on
autoconfigure : could not link against libboost_thread. what might be
going
wrong?

On Sat, Feb 16, 2013 at 8:39 AM, Zulfiqar Khan
[email protected]wrote:

I tried with boost-1.37 and boost-1.40 but its giving me error on
autoconfigure : could not link against libboost_thread. what might be going
wrong?

Are you sure that you have all of the required boost components
installed?
Just installing boost-dev won’t necessarily do that. The easiest thing
is
to just install ‘libboost(version)-all-dev’.

Tom

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs