GNU Radio Updated in MacPorts for OSX

I updated the MacPorts install for GNU Radio to reflect the new 3.7.0
release and changes to the master and next branches. Here are the new
ports (and, some related):

  • gnuradio-legacy: the latest 3.6.5 release (currently

  • gnuradio: the current release (3.7.0 right now).

  • gnuradio-devel: the current ‘master’ branch (3.7.1.git.2c05acc1 from
    2013-06-29 right now).

  • gnuradio-next: the current ‘next’ branch (3.8.0.git.eada0d6f from
    2013-06-29 right now).

If you use OSMOSDR, then you’ll need the version that matches that from
a gnuradio port:

  • gr-osmosdr-legacy: the current ‘gr3.6’ branch; must use
    gr-osmosdr-legacy too.

  • gr-osmosdr: the current ‘master’ branch; can use gnuradio or
    gnuradio-devel, but not gnuradio-next (at least for now).

Since there is no real “release” version of gr-osmosdr, there are just
the 2 options. All of the gnuradio* and gr-osmosdr* ports use the same
variant names including +full.

If you are trying out the new HackRF Jawbreaker, their GNU Radio
interface is provided by gr-osmosdr* using the +hackrf variant, or
directly via the hackrf port which is kept up with their master branch.

Happy GNU Radio hacking on OSX! - MLD

Struggling for weeks to get my new HackRF Jawbreaker from Michael Ossman
working well on Mac OSX.

I decided to start afresh a few hours ago.
Completely uninstalled MacPorts and cleaned out all the old
New fresh install of MacPorts 2.1.3 on Mac OSX 10.8.4

Installed the rtl-sdr, libusb and sox ports to test a RTL2832 device and
all looking good so then I did:

sudo port install gnuradio

this was going really nicely until I hit:

—> Activating qwt @5.1.2_2+qt4
Error: org.macports.activate for port qwt returned: Image error:
/opt/local/include/qwt/qwt.h is being used by the active qwt52 port.
Please deactivate this port first, or use ‘port -f activate qwt’ to
force the activation.
Error: Failed to install qwt

I would appreciate any advice on how best to handle this.