GNU Radio Mac OSX Install Problem - Please help

Hi all,

I checked out the latest GNU Radio on the SVN, which I know is
I’m currently trying to install it, but I’m having some problems.
I’m following the installation guide found at: with MacPorts

Here’s my problem:

I’ve passed: sed -e ‘s@libtool@glibtool@g’ etc… and on the very next
I get this issue.

[dhcp-78-152-246:~/gnuradio] frank% sudo sh bootstrap_mp
aclocal: aclocal: file `config/ltversion.m4’ does not exist error: possibly undefined macro: AM_CONFIG_HEADER
If this token and others are legitimate, please use
See the Autoconf documentation. error: possibly undefined macro: AM_INIT_AUTOMAKE error: possibly undefined macro: AM_PROG_AS error: possibly undefined macro: AC_LIBTOOL_WIN32_DLL error: possibly undefined macro: AC_ENABLE_SHARED error: possibly undefined macro: AC_DISABLE_STATIC error: possibly undefined macro: AC_PROG_LIBTOOL error: possibly undefined macro: AM_CONDITIONAL error: possibly undefined macro: AM_PATH_CPPUNIT error: possibly undefined macro: AC_MSG_ERROR
autoheader: error: AC_CONFIG_HEADERS not found in no proper invocation of AM_INIT_AUTOMAKE was found. You should verify that invokes
AM_INIT_AUTOMAKE, that aclocal.m4 is present in the top-level directory, and that aclocal.m4 was recently regenerated (using

I’m confused and sure could use some guidance. Thanks all.

Also, does anyone know if v3.0.4’s found in
/gnuradio/gnuradio-examples/python/digital/ has the option to get the
from a file? Thanks

  • Jeffrey

Jeffrey - I assume you’re trying to compile for a MacOSX box, running
10.4.X, yes?

I can tell you that the latest SVN trunk does compile cleanly on my
Intel-iMac running 10.4.10 & latest updated, XCode 2.4.1, and
MacPorts as you mention in my install guide. It also works on my PPC-
Macs, though those generally require a drop-in USB 2.0 (pc)card for
accessing the USRP since most of the default PPC-hardware isn’t
particularly optimized for USB.

Just guessing, but it looks like you have the wrong version of
autotools installed, and/or you don’t have /opt/local/bin in your
$PATH. For the former, running “port installed | grep auto” returns
for me:

autoconf @2.61_1 (active)
automake @1.10_0 (active)

For the latter, running “printenv PATH” returns for me:


Note that /opt/local/bin needs to come before /usr/bin, which
contains autoconf (2.59) and automake (1.6.3).

If you need more help on getting your OSX install running, I can do
so off-list; if we discover anything useful, I’ll report back to the
list. - MLD