Gnu radio install problems CMake Error with UHD_LIBRARIES

Hi I’m trying to install gnuradio and I have used the following command
to
retrieve the source code (after yum install gnuradio resulted in “no
package gnuradio available”): git clone --recursive git://
git.gnuradio.org/gnuradio
After making the build directory, cd to build, and the following command
cmake …/, this is the result:

Gnuradio disabled components

– ######################################################
– * sphinx
– * gr-ctrlport
– * gr-comedi
– * gr-video-sdl
– * gr-zeromq

– Using install prefix: /usr/local
– Building for version: 3.7.8 / 3.7.8
CMake Error: The following variables are used in this project, but they
are
set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the
CMake
files:
UHD_LIBRARIES
linked by target “gnuradio-uhd” in directory
/home/alneale/gnuradio/gr-uhd/lib
linked by target “_uhd_swig” in directory
/home/alneale/gnuradio/gr-uhd/swig

– Configuring incomplete, errors occurred!
See also “/home/alneale/gnuradio/build/CMakeFiles/CMakeOutput.log”.
See also “/home/alneale/gnuradio/build/CMakeFiles/CMakeError.log”.

I got the same error from trying to use the build-gnuradio.sh script.
I tried to set the variable in the CMakeLists.txt file but that did not
work, I’m not sure I was modifying the right file or using the right
syntax.
I am running CentOS 6.7 on a 32 bit pentium machine.
Thanks

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs