GNRU Radio Build issues on native Ubuntu (Jaunty)

Have given up on WUBI (Lucid) environment and build/install according to
gnuradio…/wiki/gnuradio/UbuntuInstall on a native Ubuntu(Jaunty)

Decided to install boost_1_37_0 as _1_44_0 which I used previously as it
was the latest version, did not conform to instructions on above wiki.

This allowed me (Under Installing GNU Radio section) to ./configure
–with -boost=$BOOST_PREFIX which had been an issue on the other
computer with Boost_1_44_0.

Unfortunately, the next command, make
bombs out with:

/usr/include/boost/program_options/detail/parsers.hpp:75: undefined
reference to
boost::program_options::detail::cmdline::set_additional_parser(boost::function1<std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::basic_string<char, std::char_traits<char>, std::allocator<char> > >, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::allocator<boost::function_base> >)' collect2: ld returned 1 exit status make[4]: *** [gnuradio-config-info] Error 1 make[4]: Leaving directory/home/john/gnuradio/gnuradio-core/src/lib’
make[3]: *** [install-recursive] Error 1
make[3]: Leaving directory /home/john/gnuradio/gnuradio-core/src/lib' make[2]: *** [install-recursive] Error 1 make[2]: Leaving directory/home/john/gnuradio/gnuradio-core/src’
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/home/john/gnuradio/gnuradio-core’
make: *** [install-recursive] Error 1

Has anyone experienced something similar?

Kind Regards,

            John

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs