Gmsk2 (new tunnel.py)

I’ve got two machines with one usrp each using basic tx/rx board pairs.

As soon as I start tunnel.py on each and set the ip’s, one machine
(usually the one started second) starts showing BBBBBBBBBBBBBBBBB…

If i disconnect wires, both sides go silent, reconnect and one or both
start showing BBBBBBBBBBBBBBBBb…

what is the ‘B’ anyway?

I cannot ping between the hosts… what am I missing?

On Thu, Jun 22, 2006 at 03:32:10PM -0500, Brett L Trotter wrote:

I’ve got two machines with one usrp each using basic tx/rx board pairs.

As soon as I start tunnel.py on each and set the ip’s, one machine
(usually the one started second) starts showing BBBBBBBBBBBBBBBBB…

If i disconnect wires, both sides go silent, reconnect and one or both
start showing BBBBBBBBBBBBBBBBb…

what is the ‘B’ anyway?

‘B’ means “backoff”.
It prints a B everytime it attempts to transmit if it detects carrier.

I cannot ping between the hosts… what am I missing?

First off, this example will only work with RFX-* daugherboards, not
the basic tx and rx board. Why: we currently can’t enable/disable the
transmitter on the basic tx board.

If using a RFX-* board and you see this, try setting the rx gain lower
and/or the carrier sense threshold higher.

$ tunnel --help

will give help :wink:

Eric

Eric B. wrote:

and/or the carrier sense threshold higher.

$ tunnel --help

will give help :wink:

Eric

Thanks for your wonderful help and patience so far.

I’ve gotten rid of the B’s with sufficently high -c options, but ping
still isnt happening…

A:
./tunnel.py --freq 102.0M --bitrate 500k -c 80
(other terminal) ifconfig gr0 10.10.10.1
(other terminal) ping 10.10.10.2
also tried with route add -host 10.10.10.2 gr0

B:
./tunnel.py --freq 102.0M --bitrate 500k -c 80
(other terminal) ifconfig gr0 10.10.10.2
(other terminal) ping 10.10.10.1
also tried with route add -host 10.10.10.1 gr0

both pings fail… though I’m getting nice Tx: len(payload) messages with
sizes from 42-283 on both sides.

I’ve got to be missing something silly at this point- i’ve got cables
between the machines RX->TX and TX->RX cross connect with SMA cable,
though cables are about 1M (I don’t have 3M cables just this second).
Could cable length be my problem?

Thanks again.

On Thu, Jun 22, 2006 at 03:59:26PM -0500, Brett L Trotter wrote:

Eric B. wrote:

On Thu, Jun 22, 2006 at 03:32:10PM -0500, Brett L Trotter wrote:

First off, this example will only work with RFX-* daugherboards, not
the basic tx and rx board. Why: we currently can’t enable/disable the
transmitter on the basic tx board.

Thanks for your wonderful help and patience so far.

I’ve gotten rid of the B’s with sufficently high -c options, but ping
still isnt happening…

As I said above, this example will NOT work with the Basic Tx and
Basic Rx daughterboards.

Eric

How does your physical setup look like?, i.e., how did you connect the
RX to the TX? There were a couple of messages on this mailing list
about that a couple of days ago…

Cheers,

Thomas

I’m trying to do a simple loopback using the RFX-2400. I have written
custom source and sink blocks, and everything works fine when I connect
them directly [e.g, fg.connect ( src, dst)]. However, I get weird data
in my output file when I put the USRP between them [e.g., fg.connect (
src, u_snk); fg.connect ( u_src, dst)]. There is obviously something I
do not understand about the board I’m using. I’ve attached my (short)
script, and would greatly appreciate it if one of you gurus would take a
look. Oh, and I’m connecting the Tx/Rx port directly to the Rx port w/
3ft of coax.

Thanks,
Lee

I’m directly connecting the Tx/Rx port to the Rx2 port with some coax,
no attenuators.

I looked througth the list, and found some potentially helpful threads,
but nothing that answers my question. (As far as I can tell, anyway.)

http://lists.gnu.org/archive/html/discuss-gnuradio/2006-04/msg00239.html
http://lists.gnu.org/archive/html/discuss-gnuradio/2006-06/msg00252.html

Thanks,
-Lee

----- Original Message -----
From: Thomas S. [email protected]
Date: Friday, June 23, 2006 0:36 am
Subject: Re: [Discuss-gnuradio] RFX-2400 Loopback
To: Lee P. [email protected]
Cc: [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs