Gmailer library problem


#1

I’ve been using the gmail library in ruby to connect to gmail for some
time, but now I get the following error:
/usr/lib/ruby/1.8/net/http.rb:1556:in read_status_line': wrong status line: "<HTML><HEAD><meta http-equiv=\"content-type\" content=\"text/html;charset=utf-8\">" (Net::HTTPBadResponse) from /usr/lib/ruby/1.8/net/http.rb:1538:inread_new’
from /usr/lib/ruby/1.8/net/http.rb:833:in request' from /usr/lib/ruby/1.8/net/http.rb:615:inget’
from ./gmailer.rb:196:in connect_no_cookie' from ./gmailer.rb:195:instart’
from ./gmailer.rb:195:in connect_no_cookie' from ./gmailer.rb:123:ininitialize’
from ./gmailer.rb:1767:in new' from ./gmailer.rb:1767:inconnect’

Does anyone know what the problem is? I didn’t change any of my code, so
I don’t know why it’s doing this now. Also, I tried connecting (using
the same code, but just different username and password) to a different
gmail account I have, and that works fine…


#2

Hi,

content=“text/html;charset=utf-8”>" (Net::HTTPBadResponse)
Does anyone know what the problem is? I didn’t change any of my code, so
I don’t know why it’s doing this now. Also, I tried connecting (using
the same code, but just different username and password) to a different
gmail account I have, and that works fine…

What’s your ruby version and gmailer version?

I recommend you to use 1.8.4-17 rc 2 installer and gmailer 0.1.1

Regards,

Park H.


#3

Hi. I have 1.8.4 installed, but I get the same error. (What is 1.8.4-17
rc 2 installer? Do I need to have that also? I’m a noob with all
this…)

Thanks

Park H. wrote:

Hi,

content=“text/html;charset=utf-8”>" (Net::HTTPBadResponse)
Does anyone know what the problem is? I didn’t change any of my code, so
I don’t know why it’s doing this now. Also, I tried connecting (using
the same code, but just different username and password) to a different
gmail account I have, and that works fine…

What’s your ruby version and gmailer version?

I recommend you to use 1.8.4-17 rc 2 installer and gmailer 0.1.1

Regards,

Park H.