Glib-enum-types.c error

Hi there,
I seem to have a problem getting ruby-glib to compile.

First some info about my setup:
Linux
gcc version 4.2.1
ruby 1.8.7 (2008-04-20 patchlevel 0) [i686-linux]
glib 2.16.3
gtk 2.12.9

Here the error (i downloaded from cvs from about 2 weeks ago:

glib-enum-types.c: In function ‘g_markup_collect_type_get_type’:
glib-enum-types.c:691: error: expected expression before ‘,’ token
glib-enum-types.c:692: error: extra brace group at end of initializer
glib-enum-types.c:692: error: (near initialization for ‘values[0]’)
glib-enum-types.c:692: error: expected expression before ‘,’ token
glib-enum-types.c:693: error: extra brace group at end of initializer
glib-enum-types.c:693: error: (near initialization for ‘values[0]’)
glib-enum-types.c:693: error: expected expression before ‘,’ token
glib-enum-types.c:694: error: extra brace group at end of initializer
glib-enum-types.c:694: error: (near initialization for ‘values[0]’)
glib-enum-types.c:695: error: extra brace group at end of initializer
glib-enum-types.c:695: error: (near initialization for ‘values[0]’)
make[1]: *** [glib-enum-types.o] Error 1
make[1]: Leaving directory
/Depot/j/rubygnome2-04.MAI.2008/ruby-gnome2/glib/src' make: *** [all] Error 2 make[1]: Entering directory/Depot/j/rubygnome2-04.MAI.2008/ruby-gnome2/glib/src’
gcc -I. -I. -I/Programs/Ruby/1.8.7preview2/lib/ruby/1.8/i686-linux -I.
-DHAVE_RB_DEFINE_ALLOC_FUNC -DHAVE_RB_BLOCK_PROC -DHAVE_OBJECT_ALLOCATE
-DHAVE_NODE_ATTRASGN -DHAVE_G_THREAD_INIT -DHAVE_G_MAIN_DEPTH
-DHAVE_G_LISTENV -DHAVE_RB_CHECK_ARRAY_TYPE -DHAVE_RB_EXEC_RECURSIVE
-DHAVE_RUBY_SET_CURRENT_SOURCE -DRUBY_GLIB2_COMPILATION
-D_FILE_OFFSET_BITS=64
-I/Programs/Ruby/1.8.7preview2/lib/ruby/site_ruby/1.8/i686-linux -fPIC
-O2 -march=i686 -fomit-frame-pointer -frerun-loop-opt -fPIC -Wall
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -pthread
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -c
glib-enum-types.c
glib-enum-types.c: In function ‘g_markup_collect_type_get_type’:
glib-enum-types.c:691: error: expected expression before ‘,’ token
glib-enum-types.c:692: error: extra brace group at end of initializer
glib-enum-types.c:692: error: (near initialization for ‘values[0]’)
glib-enum-types.c:692: error: expected expression before ‘,’ token
glib-enum-types.c:693: error: extra brace group at end of initializer
glib-enum-types.c:693: error: (near initialization for ‘values[0]’)
glib-enum-types.c:693: error: expected expression before ‘,’ token
glib-enum-types.c:694: error: extra brace group at end of initializer
glib-enum-types.c:694: error: (near initialization for ‘values[0]’)
glib-enum-types.c:695: error: extra brace group at end of initializer
glib-enum-types.c:695: error: (near initialization for ‘values[0]’)

Hi,

In [email protected]
“[ruby-gnome2-devel-en] glib-enum-types.c error” on Sat, 17 May 2008
22:52:34 +0200,
Marc H. [email protected] wrote:

I seem to have a problem getting ruby-glib to compile.

First some info about my setup:
Linux
gcc version 4.2.1
ruby 1.8.7 (2008-04-20 patchlevel 0) [i686-linux]
glib 2.16.3
gtk 2.12.9

Here the error (i downloaded from cvs from about 2 weeks ago:

Use svn.

Thanks,

kou

Use svn.

Thanks kou,
it worked!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs