Glassfish gem 0.9 problems


#1

Hi guys!
I’m testing the glassfish-gem 0.9 and I got some errors when I start
my rails application.
I’m using jruby 1.1.5, glassfish-gem 0.9, rack 0.4 and rails 2.1.2
In osx everything works fine!
In Windows Server 2003 I got this error: http://pastie.org/315583
In Ubuntu 8.04.1 I have a different error: http://pastie.org/315584
My sample application works fine with jetty-rails and webrick in
osx,windows, and ubuntu.

Thanks. Your work with jruby is really amazing! I did some benchmarks,
and I got numbers where jruby 1.1.5 is 2 times faster than mri, even
on Windows.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#2

Luís Gustavo Lima Silva wrote:

Hi guys!
I’m testing the glassfish-gem 0.9 and I got some errors when I start
my rails application.
I’m using jruby 1.1.5, glassfish-gem 0.9, rack 0.4 and rails 2.1.2
In osx everything works fine!
In Windows Server 2003 I got this error: http://pastie.org/315583
In Ubuntu 8.04.1 I have a different error: http://pastie.org/315584
My sample application works fine with jetty-rails and webrick in
osx,windows, and ubuntu.

The Windows error looks like a pathing bug, either in JRuby proper or
part of GlassFish. Can you run the application with e.g. Mongrel on
Windows?

The Ubuntu error has a bunch of OSGI noise in it…can you file it with
the GlassFish team?

https://glassfish.dev.java.net/servlets/ProjectIssues

You’ll need to login or register there. Hopefulyl GlassFish folks will
see this thread as well. There’s a plan for a 0.9.1 release of the gem
very soon, and it would be nice to see both of these fixed.

Thanks. Your work with jruby is really amazing! I did some benchmarks,
and I got numbers where jruby 1.1.5 is 2 times faster than mri, even
on Windows.

Excellent! What sort of benchmarks were they?

  • Charlie

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#3

I can run my application with Mongrel on Windows. With jetty-rails and
webrick too.My benchmarks are here: http://www.pastie.org/316132

Thanks!

Luis

2008/11/16 Charles Oliver N. removed_email_address@domain.invalid


#4

Ok, I’m guessing both issues are in GlassFish then…can you file bugs
with the GlassFish guys?

The first issue is probably GF not correctly handling the path to the
application. The second, I have no idea.

https://glassfish.dev.java.net/servlets/ProjectIssues

Luís Gustavo Lima Silva wrote:

mailto:removed_email_address@domain.invalid>
My sample application works fine with jetty-rails and webrick in
https://glassfish.dev.java.net/servlets/ProjectIssues


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#5

I’ve posted in glassfish gem issue tracker:
http://rubyforge.org/tracker/index.php?func=detail&aid=22836&group_id=5450&atid=21080
Luis
www.twitter.com/luisbebop

2008/11/16 Charles Oliver N. removed_email_address@domain.invalid


#6

I can report the same http://pastie.org/315584 problem on Ubuntu 8.10
Is there a cure?

On Sat, Nov 15, 2008 at 7:02 PM, Luís Gustavo Lima Silva <


#7

Thanks Luis,
Good news!

On Wed, Dec 3, 2008 at 8:20 PM, Luís Gustavo Lima Silva
<removed_email_address@domain.invalid


#8

Hi Nick.In the next release of glassfish gem (0.9.1) both errors which I
reported will be fixed.
Vivek P. fixed both.

http://rubyforge.org/tracker/?func=detail&atid=21080&aid=22836&group_id=5450

2008/11/24 Nick C. removed_email_address@domain.invalid