GIT checkout of Gnu Radio failed!

I am installing GNU Radio from this link :
http://blogs.bu.edu/mhirsch/2012/07/installing-gnu-radio-in-ubuntu-12-04-x64/comment-page-1/
but I got this output in terminal :

“This script will fetch Gnu Radio version 3.7/maint from the
repositories,
along with compatible
extras.
Is this OK?Y
Fetching various packages (Gnu Radio, UHD, gr-osmosdr, gr-iqbal, etc)
via the Internet
=======> THIS MAY TAKE QUITE SOME TIME <=========
Fetching Gnu Radio via GIT…Cloning into ‘gnuradio’…
error: Unable to get pack file
http://gnuradio.org/git/gnuradio.git/objects/pack/pack-4efcc5d853d522a5d355d67387c7f37121663227.pack
transfer closed with 20430353 bytes remaining to read
error: Unable to find 6d7dd3f7609d9ec26acefdf040be0e8bb77a222c under
http://gnuradio.org/git/gnuradio.git
Cannot obtain needed object 6d7dd3f7609d9ec26acefdf040be0e8bb77a222c
while processing commit 85ae8fc1e6b7397eb6dc774e2e4eaf8049265b13.
error: Fetch failed.
Could not find gnuradio/gnuradio-{core,runtime} after GIT checkout
GIT checkout of Gnu Radio failed!
Send success/fail info to sbrac.org?Y

then I tried git clone --verbose & --progress
http://gnuradio.org/git/gnuradio.git and i got the same output , what
can i
do ? …thanks in advance:)

[email protected]:~/gnuradio$ git clone --verbose
http://gnuradio.org/git/gnuradio.git
Cloning into ‘gnuradio’…
error: Unable to get pack file
http://gnuradio.org/git/gnuradio.git/objects/pack/pack-4efcc5d853d522a5d355d67387c7f37121663227.pack
transfer closed with 21869664 bytes remaining to read
error: Unable to find 6d7dd3f7609d9ec26acefdf040be0e8bb77a222c under
http://gnuradio.org/git/gnuradio.git
Cannot obtain needed object 6d7dd3f7609d9ec26acefdf040be0e8bb77a222c
while processing commit 85ae8fc1e6b7397eb6dc774e2e4eaf8049265b13.
error: Fetch failed.

[email protected]:~/gnuradio$ git clone --progress
http://gnuradio.org/git/gnuradio.git
Cloning into ‘gnuradio’…
error: Unable to get pack file
http://gnuradio.org/git/gnuradio.git/objects/pack/pack-4efcc5d853d522a5d355d67387c7f37121663227.pack
transfer closed with 21283224 bytes remaining to read
error: Unable to find 6d7dd3f7609d9ec26acefdf040be0e8bb77a222c under
http://gnuradio.org/git/gnuradio.git
Cannot obtain needed object 6d7dd3f7609d9ec26acefdf040be0e8bb77a222c
while processing commit 85ae8fc1e6b7397eb6dc774e2e4eaf8049265b13.
error: Fetch failed.

On Thu, Mar 27, 2014 at 11:21 AM, Sara C. [email protected]
wrote:

I am installing GNU Radio from this link :

http://blogs.bu.edu/mhirsch/2012/07/installing-gnu-radio-in-ubuntu-12-04-x64/comment-page-1/

but I got this output in terminal :

We’re getting various reports of problems with git over http access to
gnuradio.org. We think it’s something going on with our hosting
platform.

You can change that line in the build script from
http://git.gnuradio.org/git/gnuradio.git to
https://github.com/gnuradio/gnuradio.git.

Tom

I tried this command but I got this output :
[email protected]:~/gnuradio$ git clone --progress
https://github.com/gnuradio/gnuradio.git.
Cloning into ‘gnuradio.git.’…
fatal: https://github.com/gnuradio/gnuradio.git./info/refs not found:
did
you run git update-server-info on the server?
I searched for the problem , I found in this link that i have to change
in
./git/config
http://stackoverflow.com/questions/9343189/did-you-run-git-update-server-info-error-on-a-github-repository
but I didn’t find this file , where can i find it (sorry i am new to
Ubuntu )

Then I found in the file named " build-gnuradio " this line
git clone --progress http://git.gnuradio.org/git/gnuradio.git >>$LOGDEV
2>&1
and i changed it to:
git clone --progress https://github.com/gnuradio/gnuradio.git >>$LOGDEV
2>&1
as you said

But I have the same output!!
Fetching Gnu Radio via GIT…Cloning into ‘gnuradio’…
error: Unable to get pack file
http://gnuradio.org/git/gnuradio.git/objects/pack/pack-4efcc5d853d522a5d355d67387c7f37121663227.pack
transfer closed with 17230768 bytes remaining to read
error: Unable to find 6d7dd3f7609d9ec26acefdf040be0e8bb77a222c under
http://gnuradio.org/git/gnuradio.git
Cannot obtain needed object 6d7dd3f7609d9ec26acefdf040be0e8bb77a222c
while processing commit 85ae8fc1e6b7397eb6dc774e2e4eaf8049265b13.
error: Fetch failed.
Could not find gnuradio/gnuradio-{core,runtime} after GIT checkout
GIT checkout of Gnu Radio failed!
Send success/fail info to sbrac.org?Y

2014-03-27 20:35 GMT+02:00 Tom R. [email protected]:

The config file ist located in .git ( hidden directory) not in ./git

– Volker

Am 27.03.2014 21:25, schrieb Sara C.:

On Thu, Mar 27, 2014 at 1:25 PM, Sara C. [email protected]
wrote:

I tried this command but I got this output :
[email protected]:~/gnuradio$ git clone --progress
https://github.com/gnuradio/gnuradio.git.
Cloning into ‘gnuradio.git.’…
fatal: https://github.com/gnuradio/gnuradio.git./info/refs not found: did
you run git update-server-info on the server?

I just tried this and it works. It looks like the URI you were trying
had a period after .git, which would cause it to not work. Make sure
the URI doesn’t have a period at the end exactly like this: git clone
–progress https://github.com/gnuradio/gnuradio.git

git clone --progress https://github.com/gnuradio/gnuradio.git >>$LOGDEV
error: Unable to find 6d7dd3f7609d9ec26acefdf040be0e8bb77a222c under
http://gnuradio.org/git/gnuradio.git
Cannot obtain needed object 6d7dd3f7609d9ec26acefdf040be0e8bb77a222c
while processing commit 85ae8fc1e6b7397eb6dc774e2e4eaf8049265b13.
error: Fetch failed.
Could not find gnuradio/gnuradio-{core,runtime} after GIT checkout
GIT checkout of Gnu Radio failed!
Send success/fail info to sbrac.org?Y

I didn’t follow what you did there, but it doesn’t sound helpful.

Yes , I tried it again & it works :slight_smile:
Thanks Tom , Volker & Nathan .
I ran gnuradio in terminal after installing & I see there is no problem
in
it
[email protected]:~/gnuradio$ gnuradio-companion
Warning: Block key “blocks_ctrlport_monitor_performance” not found when
loading category tree.
Warning: Block key “blocks_ctrlport_monitor_performance” not found when
loading category tree.
linux; GNU C++ version 4.6.3; Boost_104800; UHD_003.007.000-53-g6962543f
<<< Welcome to GNU Radio Companion 3.7.3 >>>
Showing: “”

BUT when installing it , after 3 hours of installation , I got an output
which shows that GNURADIO_CORE & GRUEL LIBRARIES are not found ! is
there
a problem , or these libraries are not important ? Do I have to
uninstall &
install again?!
also it is saying : "You will not be able to access your USRP1 device
until
you do this… " … I will use B100 & B200 , is there any problem ? Any
problem will occur when using my usrps?!

also it is saying : " You should probably set your PYTHONPATH to:
/usr/local/lib/python2.7/dist-packages Using:
export PYTHONPATH=/usr/local/lib/python2.7/dist-packages in your
.bashrc
or equivalent file prior to attempting to run
any Gnu Radio applications or Gnu Radio Companion. "
what is the importance to do that ,as I ran gnuradio now ? I found a
.bashrc file in home directory , is this the meant file? I will copy
paste
“export PYTHONPATH=/usr/local/lib/python2.7/dist-packages” to the end of
file , tell me if this is not right.

Thanks &
Here is the output in terminal during installation:

Starting function extras at: Fri Mar 28 18:20:28 EET 2014
mv: cannot stat `gr-baz’: No such file or directory
Doing GIT checkout for extra module gr-baz
Cloning into ‘gr-baz’…
remote: Reusing existing pack: 1101, done.
remote: Total 1101 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (1101/1101), 798.65 KiB | 51 KiB/s, done.
Resolving deltas: 100% (579/579), done.
Building extra module gr-baz
– The CXX compiler identification is GNU
– The C compiler identification is GNU
– Check for working CXX compiler: /usr/bin/c++
– Check for working CXX compiler: /usr/bin/c++ – works
– Detecting CXX compiler ABI info
– Detecting CXX compiler ABI info - done
– Check for working C compiler: /usr/bin/gcc
– Check for working C compiler: /usr/bin/gcc – works
– Detecting C compiler ABI info
– Detecting C compiler ABI info - done
– Build type not specified: defaulting to release.
– Boost version: 1.48.0
– Found the following Boost libraries:
– system
– thread
– checking for module ‘gruel’
– package ‘gruel’ not found
– Could NOT find GRUEL (missing: GRUEL_LIBRARIES GRUEL_INCLUDE_DIRS)
– checking for module ‘gnuradio-core’
– package ‘gnuradio-core’ not found
– Could NOT find GNURADIO_CORE (missing: GNURADIO_CORE_LIBRARIES
GNURADIO_CORE_INCLUDE_DIRS)
CMake Error at CMakeLists.txt:135 (message):
Gruel required to compile baz

– Configuring incomplete, errors occurred!
make: *** No targets specified and no makefile found. Stop.
make: *** No rule to make target install'. Stop. mv: cannot statgrextras’: No such file or directory
Doing GIT checkout for extra module grextras
Cloning into ‘grextras’…
remote: Reusing existing pack: 4066, done.
remote: Total 4066 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (4066/4066), 4.50 MiB | 55 KiB/s, done.
Resolving deltas: 100% (1996/1996), done.
Building extra module grextras
– The CXX compiler identification is GNU
– The C compiler identification is GNU
– Check for working CXX compiler: /usr/bin/c++
– Check for working CXX compiler: /usr/bin/c++ – works
– Detecting CXX compiler ABI info
– Detecting CXX compiler ABI info - done
– Check for working C compiler: /usr/bin/gcc
– Check for working C compiler: /usr/bin/gcc – works
– Detecting C compiler ABI info
– Detecting C compiler ABI info - done
– Build type not specified: defaulting to release.
– Boost version: 1.48.0
– checking for module ‘volk’
– found volk, version 0.1
– Found VOLK: /usr/local/lib/libvolk.so
– checking for module ‘gruel’
– package ‘gruel’ not found
– Could NOT find GRUEL (missing: GRUEL_LIBRARIES GRUEL_INCLUDE_DIRS)
– checking for module ‘gnuradio-core’
– package ‘gnuradio-core’ not found
– Could NOT find GNURADIO_CORE (missing: GNURADIO_CORE_LIBRARIES
GNURADIO_CORE_INCLUDE_DIRS)
CMake Error at CMakeLists.txt:112 (message):
Gruel required to compile extras

– Configuring incomplete, errors occurred!
make: *** No targets specified and no makefile found. Stop.
make: *** No rule to make target `install’. Stop.
Done function extras at: Fri Mar 28 18:22:31 EET 2014
Starting function mod_groups at: Fri Mar 28 18:22:31 EET 2014


This script has just modified /etc/group to place your userid
‘(’$USER’)’
into group ‘usrp’
In order for this change to take effect, you will need to log-out and
log
back
in again. You will not be able to access your USRP1 device until you do
this.

If you wish to allow others on your system to use the USRP1 device, you
will need to use:

sudo usermod -a -G usrp userid

For each userid you wish to allow access to the usrp


Further
Done function mod_groups at: Fri Mar 28 18:22:33 EET 2014
Starting function mod_udev at: Fri Mar 28 18:22:33 EET 2014
Done function mod_udev at: Fri Mar 28 18:22:33 EET 2014
Starting function mod_sysctl at: Fri Mar 28 18:22:33 EET 2014
Applying updates to /etc/sysctl.conf
Group ‘usrp’ now has real-time scheduling privileges
You will need to log-out and back in again for this to
take effect
Done function mod_sysctl at: Fri Mar 28 18:22:33 EET 2014
Starting function pythonpath at: Fri Mar 28 18:22:33 EET 2014


You should probably set your PYTHONPATH to:

 /usr/local/lib/python2.7/dist-packages

Using:

export PYTHONPATH=/usr/local/lib/python2.7/dist-packages

in your .bashrc or equivalent file prior to attempting to run
any Gnu Radio applications or Gnu Radio Companion.


Done function pythonpath at: Fri Mar 28 18:22:33 EET 2014
Done all functions at: Fri Mar 28 18:22:33 EET 2014
All Done
Send success/fail info to sbrac.org?Y
Thanks

2014-03-27 22:38 GMT+02:00 West, Nathan [email protected]:

<<< Welcome to GNU Radio Companion 3.7.3 >>>

Thanks &
Building extra module gr-baz
– Build type not specified: defaulting to release.
GNURADIO_CORE_INCLUDE_DIRS)
remote: Reusing existing pack: 4066, done.
– Check for working C compiler: /usr/bin/gcc
– Could NOT find GRUEL (missing: GRUEL_LIBRARIES GRUEL_INCLUDE_DIRS)
make: *** No rule to make target `install’. Stop.
If you wish to allow others on your system to use the USRP1 device,
Starting function mod_udev at: Fri Mar 28 18:22:33 EET 2014



mailto:[email protected]>:

>
> git clone --progress https://github.com/gnuradio/gnuradio.git
> transfer closed with 17230768 bytes remaining to read
I didn't follow what you did there, but it doesn't sound helpful.

Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
gr-baz and grextras haven’t been updated to use the GR 3.7 API, so their
builds will fail, but since they’re optional, no big deal.

Also, YES, set your PYTHONPATH as directed.

You should probably learn a bit about being a Linux user–we can’t
possibly take on that role on this mailing list. Environment variables
(such as PYTHONPATH) are a “natural” thing in the Linux world, and
learning where/when to set them is important general Linux knowledge,
not specifically related to Gnu Radio. In THIS case, you need to set
the PYTHONPATH to include the location where the gnuradio installer
installed all its bits and pieces, or Python won’t be able to find
them, and things won’t work.

Since the build-gnuradio script has no way of reliably editing-in the
necessary PYTHONPATH setting into your .bashrc, it gives you a printed
notice giving you hints about what to set it to, and where.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs