Getting fcgi to work


#1

can some one help me with my install? i’m having a touch time getting
fcgi to play right with apache. i ran “gem install fcgi” and this is the
output i get:

Attempting local installation of ‘fcgi’
Local gem file not found: fcgi*.gem
Attempting remote installation of ‘fcgi’
Updating Gem source index for: http://gems.rubyforge.org
Building native extensions. This could take a while…
ruby extconf.rb install fcgi
checking for fcgiapp.h… yes
checking for FCGX_Accept() in -lfcgi… yes
creating Makefile

make
gcc -fPIC -g -O2 -I. -I/usr/local/lib/ruby/1.8/i686-linux
-I/usr/local/lib/ruby/1.8/i686-linux -I. -DHAVE_FCGIAPP_H -c fcgi.c
gcc -shared -L’/usr/local/lib’ -Wl,-R’/usr/local/lib’ -o fcgi.so fcgi.o
-lfcgi -ldl -lcrypt -lm -lc

make install
/usr/bin/install -c -m 0755 fcgi.so
/usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.6.1/.
Successfully installed fcgi-0.8.6.1
Installing RDoc documentation for fcgi-0.8.6.1…

No definition for fcgi_s_accept

No definition for fcgi_s_each

No definition for fcgi_s_each

No definition for fcgi_s_iscgi

No definition for fcgi_in

No definition for fcgi_out

No definition for fcgi_err

No definition for fcgi_env

No definition for fcgi_finish

No definition for fcgi_stream_putc

No definition for fcgi_stream_write

No definition for fcgi_stream_print

No definition for fcgi_stream_printf

No definition for fcgi_stream_puts

No definition for fcgi_stream_addstr

No definition for fcgi_stream_flush

No definition for fcgi_stream_getc

No definition for fcgi_stream_ungetc

No definition for fcgi_stream_gets

No definition for fcgi_stream_read

No definition for fcgi_stream_eof

No definition for fcgi_stream_eof

No definition for fcgi_stream_close

No definition for fcgi_stream_closed

No definition for fcgi_stream_binmode

No definition for fcgi_stream_isatty

No definition for fcgi_stream_isatty

No definition for fcgi_stream_sync

No definition for fcgi_stream_setsync

am i supposed to get those no definition messages? are those errors or
what? this is what i get when trying to run my rails apps with fcgi:

/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/dependencies.rb:112:in
const_missing': uninitialized constant RailsFCGIHandler (NameError) from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/dependencies.rb:120:inconst_missing’
from /home/mymedia/public_html/rails/dispatch.fcgi:26
[Mon Apr 3 01:16:03 2006] [warn] FastCGI: (dynamic) server
“/home/mymedia/public_html/rails/dispatch.fcgi” (pid 28269) terminated
by calling exit with status ‘1’
[Mon Apr 3 01:16:06 2006] [warn] FastCGI: (dynamic) server
“/home/mymedia/public_html/rails/dispatch.fcgi” restarted (pid 28270)
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/dependencies.rb:112:in
const_missing': uninitialized constant RailsFCGIHandler (NameError) from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/dependencies.rb:120:inconst_missing’
from /home/mymedia/public_html/rails/dispatch.fcgi:26
[Mon Apr 3 01:16:08 2006] [warn] FastCGI: (dynamic) server
“/home/mymedia/public_html/rails/dispatch.fcgi” (pid 28270) terminated
by calling exit with status ‘1’

i have no idea what any of this means. if anyone can help me out or
point me in the right direction, that would be great!

thanks,
josh


#2

Am Montag, den 03.04.2006, 13:39 +0200 schrieb Josh K.:

checking for fcgiapp.h… yes
/usr/bin/install -c -m 0755 fcgi.so
No definition for fcgi_s_iscgi

No definition for fcgi_stream_addstr

No definition for fcgi_stream_isatty
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/dependencies.rb:112:in
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/dependencies.rb:112:in
point me in the right direction, that would be great!
On what Platform are you working? Debian? Try out this HowTo:

http://blog.inlet-media.de/the-perfect-ruby-on-rails-with-apache2-and-fastcgi-setup-on-debian-sarge


Norman T.

http://blog.inlet-media.de


#3

On what Platform are you working? Debian? Try out this HowTo:

http://blog.inlet-media.de/the-perfect-ruby-on-rails-with-apache2-and-fastcgi-setup-on-debian-sarge


Norman T.

http://blog.inlet-media.de

i’m using RedHat. i have a dedicated server with hostgator.com
i’m running apache 1.3.4 i believe. what changes on this would i need to
make for apache 1.3?


#4

Josh K. wrote:

can some one help me with my install? i’m having a touch time getting
fcgi to play right with apache. i ran “gem install fcgi” and this is the
output i get:

Attempting local installation of ‘fcgi’

FWIW, I had exactly the same problem with the fcgi constant on OsX.
Even stranger, I have two macs with what I think are identical setups
and I DON’T have the problem on one of them! Probably why I switched to
mongrel at least for the time being… :slight_smile:
Very frustrating, to say the least.
Keith


#5

Am Montag, den 03.04.2006, 17:18 +0200 schrieb Josh K.:

On what Platform are you working? Debian? Try out this HowTo:

http://blog.inlet-media.de/the-perfect-ruby-on-rails-with-apache2-and-fastcgi-setup-on-debian-sarge

i’m using RedHat. i have a dedicated server with hostgator.com
i’m running apache 1.3.4 i believe. what changes on this would i need to
make for apache 1.3?

Sorry, i have no experience with RedHat or Apache 1.3, but the general
recipe should be the same as described in the howto.


Norman T.

http://blog.inlet-media.de


#6

/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/dependencies.rb:112:in

point me in the right direction, that would be great!
On what Platform are you working? Debian? Try out this HowTo:

http://blog.inlet-media.de/the-perfect-ruby-on-rails-with-apache2-and-fastcgi-setup-on-debian-sarge


Norman T.

http://blog.inlet-media.de

i’m trying to install the mod_fcgi. in the tutorial it says to use
Makefile.AP2, but with apache 133 what make file should i use.


#7

sry bout the last post. noob mistake. i still haven’t had any luck
though. on thing i did try in your tutorial was running the
dispatch.fcgi script from the shell line. i get the following errors:

/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/dependencies.rb:112:in
const_missing': uninitialized constant RailsFCGIHandler (NameError) from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.0/lib/active_support/dependencies.rb:120:inconst_missing’
from …/newtest/public/dispatch.fcgi:24

based on that, can anyone tell me what i’m doing wrong? is it my
configuration? installation maybe?