Getting error while submitting form in ruby on rails with radiant

I have issues with radiant cms version 0.8.2.In Application,when i click
on
submit on form application got an error uninitialized controller which
is
in radiant/app/controller.

error :

NameError (uninitialized constant ResourceController):
vendor/extensions/smart/app/controllers/quote_requests_controller.rb:1
/usr/lib/ruby/1.8/webrick/httpserver.rb:104:in service’
/usr/lib/ruby/1.8/webrick/httpserver.rb:65:inrun’

/usr/lib/ruby/1.8/webrick/server.rb:173:in start_thread’
/usr/lib/ruby/1.8/webrick/server.rb:162:instart’

/usr/lib/ruby/1.8/webrick/server.rb:162:in start_thread’
/usr/lib/ruby/1.8/webrick/server.rb:95:instart’

/usr/lib/ruby/1.8/webrick/server.rb:92:in each’
/usr/lib/ruby/1.8/webrick/server.rb:92:instart’

/usr/lib/ruby/1.8/webrick/server.rb:23:in start’
/usr/lib/ruby/1.8/webrick/server.rb:82:instart’

ResourceController is in
radiant/app/controllers/admin/resource_controller.rb

and in the first line of quote_requests_controller.rb, “class
QuoteRequestsController < ResourceController::Base” is there.

rails 2.3.14 ruby 1.8.7 rubygems-update (1.4.2) radiant 0.8.2

i was done googling for this issue please help me to figure out error.

Thanking You,

Nirav

i tried little bit but it doesn’t helpful to me (with the help of
googling
and stackoverflow suggestions ):

  1. “class Admin::ResourceController < ApplicationController” this is in
    resource_controller.rb file. and i also tried to put
    resource_controller.rb
    file out of admin. but it gives error LoadError (Expected
    /home/ec2-user/rubygems-1.4.2/new/vendor/radiant/app/controllers/resource_controller.rb
    to define ResourceController):
    vendor/extensions/smartmove/app/controllers/quote_requests_controller.rb:1

  2. i also tried to replace “class QuoteRequestsController <
    ResourceController::Base” to “class QuoteRequestsController <
    Admin::ResourceController” but still it gets an error will be same and i
    search by googling to add require “resource_controller” in top of the
    controller but it doesn’t help to solve an error.

Thanking You,
Nirav

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs