Getting "Could not find gem 'rack (~> 2.x) ruby'" error while running bundle for Rails 5 app

I have 5 Rails 5 "canery apps’ that in the past run bundle cleanly, but
yesterday things changed.

I have two repos (rt_demo_app5, rt_first_app5) that have run bundle
cleanly
(after adding rack

master to Gemfile) and 3 that do not (hello_app5, toy_app5,
sample_app_5_0_rt) even after

adding the rack master to Gemfile.

For the ones that do not run bundle cleanly, the error message is
(before
adding rack master to Gemfile):

Bundler could not find compatible versions for gem “rack”:
In Gemfile:
rails (>= 0) ruby depends on
actionpack (= 5.0.0.alpha) ruby depends on
rack (~> 2.x) ruby
Could not find gem ‘rack (~> 2.x) ruby’, which is required by
gem ‘actionpack (= 5.0.0.alpha) ruby’, in any of the sources.

Example Public repo: https://bitbucket.org/jasnow/sample_app_5_0_rt

https://bitbucket.org/jasnow/sample_app_5_0_rt

I checked rubygems.org and latest rack is at 1.6.4 so unclear how to get
2.x.

So how do I change my Gemfile to find “rack 2.x”?

Thanks,

Al

After adding “gem ‘rack’, github: '‘rack/rack’” to example repo below, I
get this when I run “bundle” command:

Bundler could not find compatible versions for gem “rack”:
In Gemfile:
rails (>= 0) ruby depends on
actionpack (= 5.0.0.alpha) ruby depends on
rack (~> 1.6) ruby

rack (>= 0) ruby

It appears that we need both rack (2.x) and rack (1.6).

FYI,
Al

On Fri, Aug 21, 2015 at 9:09 AM, Al Snow [email protected] wrote:

I checked rubygems.org and latest rack is at 1.6.4 so unclear how to get
2.x.

So how do I change my Gemfile to find “rack 2.x”?

Try:

gem ‘rack’, github: ‘rack/rack’

HTH,

Hassan S. ------------------------ [email protected]
http://about.me/hassanschroeder
twitter: @hassan
Consulting Availability : Silicon Valley or remote

TRICK: Must notice what is between the paras and add them to the
config/initializers/assets.rb file.
Example: Rails.application.config.assets.precompile += %w(*
application.js
application.css* ).
Once I added all of the things that needed to be precompile (now with
sprockets 4.0), “rake” ran cleanly.

Therefore all 3 repos that I had problems with today and now fixed.
(Question Closed)

Partially fix (but now have new messages):

After more digging, I added these lines to Gemfile:

    • gem ‘sprockets’, git: ‘git://github.com/rails/sprockets.git’ * gem
      ‘sass-rails’, git: ‘git://github.com/rails/sass-rails.git’ * gem
      ‘rack’, git: ‘git://github.com/rack/rack.git’ * gem
      ‘sprockets-rails’, ‘3.0.0.beta2’*

But now I get this (even aflter added the line below to
config/initializers/assets.rb) during rake run:

ActionView::Template::Error: Asset was not declared to be precompiled
in
production.Add Rails.application.config.assets.precompile += %w( application.js ) toconfig/initializers/assets.rb and restart your
server"

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs