Getting AdapterNotSpecified on simple script/generate


#1

So even after installing the sqlite3-ruby gem without issues, I still
get this error when I try to generate a model…

Attempting local installation of ‘sqlite3-ruby’
Local gem file not found: sqlite3-ruby*.gem
Attempting remote installation of ‘sqlite3-ruby’
Select which gem to install for your platform (powerpc-darwin8.3.0)

  1. sqlite3-ruby 1.1.0 (mswin32)
  2. sqlite3-ruby 1.1.0 (ruby)
  3. sqlite3-ruby 1.0.1 (ruby)
  4. sqlite3-ruby 1.0.1 (mswin32)
  5. sqlite3-ruby 1.0.0 (mswin32)
  6. sqlite3-ruby 1.0.0 (ruby)
  7. sqlite3-ruby 0.9.0 (ruby)
  8. sqlite3-ruby 0.9.0 (mswin32)
  9. sqlite3-ruby 0.6.0 (ruby)
  10. sqlite3-ruby 0.5.0 (ruby)
  11. Cancel installation

2
Building native extensions. This could take a while…
ruby extconf.rb install sqlite3-ruby
checking for sqlite3.h… yes
checking for sqlite3_open() in -lsqlite3… yes
creating Makefile

make
gcc -fno-common -g -O2 -pipe -fno-common -I.
-I/usr/local/lib/ruby/1.8/powerpc-darwin8.3.0
-I/usr/local/lib/ruby/1.8/powerpc-darwin8.3.0 -I. -DHAVE_SQLITE3_H
-I/usr/local/include -c sqlite3_api_wrap.c
cc -dynamic -bundle -undefined suppress -flat_namespace
-L"/usr/local/lib" -L"/usr/local/lib" -o sqlite3_api.bundle
sqlite3_api_wrap.o -lsqlite3 -ldl -lobjc

make install
install -c -p -m 0755 sqlite3_api.bundle
/usr/local/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.1.0/lib
Successfully installed sqlite3-ruby-1.1.0
Installing RDoc documentation for sqlite3-ruby-1.1.0…

lib/sqlite3/database.rb:637:65: Skipping require of dynamic string:
“sqlite3/driver/#{driver.to_s.downcase}/driver”

lib/sqlite3/database.rb:642:59: Skipping require of dynamic string:
“sqlite3/driver/#{d.downcase}/driver”

$ ./script/generate model Activity
/usr/local/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/connection_adapters/abstract/connection_specification.rb:73:in
establish_connection': development database is not configured (ActiveRecord::AdapterNotSpecified) from /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/connection_adapters/abstract/connection_specification.rb:66:inestablish_connection’
from
/usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:169:in
initialize_database' from /usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:83:inprocess’
from
/usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:42:in
send' from /usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:42:inrun’
from ./script/…/config/…/config/environment.rb:10
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require__' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:in
require' from /usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/generate.rb:1 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire__’
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require' from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:inrequire’
from ./script/generate:3

my database.yml file:
development:
adapter: sqlite3
database: db/development.db

test:
adapter: sqlite3
database: db/test.db

production:
adapter: sqlite3
database: db/prod.db