Getting ActionMailer off the ground

First off, I wanted to thank the list. You all have been a great help
with my rookie questions as I’m getting my RoR app off the ground. Now
to the problem I’m having with ActionMailer. No matter what I set in
ActionMailer::Base.server_settings when my app tries to send mail I get
a 501: HELO hostname error. I basically set it up matching the
ActionMailer wiki page. I’ve tried using my machine as the smtp server
with just localhost settings, and I’ve tried using my office’s smtp
server with their settings. Everytime the same error message. The log
file shows the email being created. It shows the following header
information:

Sent mail:
From: [email protected]
To: [email protected]
Subject: New ticket has been created
Content-Type: text/plain; charset=utf-8

It doesn’t show any HELO or “Received from” info in the log. Is it
supposed to? I can’t figure out why with two different smtp server
settings, I’m getting the exact same error message. I found a couple of
threads on the list that went over similar problems, but the solutions
didn’t work in my case.

If I am just using my machine as a localhost smtp server do I need to
even specify any server_settings options? I tried not specifying any and
just leaving everything at the default, but still got the 501:HELO
hostname error. Sorry for the long-winded mail, but I’ve been going in
circles for the better part of a day with this.

Any help would be greatly appreciated.

Thanks,
Dan

OK. I’ll save everyone the trouble of answering, and hopefully save
someone the hoop-jumping that I went through. After a reboot of my
machine it is working now with all of the default server settings. I’m
running ruby and rails within Locomotive, and I guess the
config/environment files are cached even after restarting the server via
Locomotive. This seems to contradict the rails docs, which say that when
running in development mode the config files are reloaded every time.
Anyways, sorry for the bandwidth.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs