GetText.update_pofiles: seeking help with error message


#1

[Re-post from Ruby list, where this didn’t belong. Sorry for the noise.]

Hi all!

Following the guide at http://manuals.rubyonrails.com/read/chapter/105,
I’m trying to i18n a Rails application. However, when executing ‘rake
updatepo’, I get the following error message:

"numeric literal without digits"

Searching Google and the mailing list archives yields only two hints.
(1) install ruby 1.8.4 and (2) make sure there’s an empty line at the
end of each file. Although I can’t seem to find the sense in the second
one, I’ve made sure my environment complies with both.

The error message still doesn’t go away… I’d be darn grateful for any
pointers that you might have :slight_smile:

Best regards from Germany,
Raphael


#2

[…]
“numeric literal without digits”
[…]

Okay, the problem solved itself. Apparently using the Dapper Drake
.debs in Ubuntu Breezy Badger in order to get ruby 1.8.4 running isn’t
the best idea (it’s suggested when you search Google).

I’ve now compiled Ruby 1.8.4 by hand and it rgettext works.

Although now it says

no such file to load – gettext/utils

coming from the line “require ‘gettext/utils’” in the Rakefile. You
guys wouldn’t know how to solve that one, would you? :slight_smile:

Bests, Raphael


#3

coming from the line “require ‘gettext/utils’” in the Rakefile. You
guys wouldn’t know how to solve that one, would you? :slight_smile:

And that is also solved.
Thanks for the nice chat everybody :slight_smile:

… it’s all just glitches with the installation here.