Gettext-2.0.1, gettext_activerecord-2.0.1, gettext_rails-2.0.1

Hi,

Ruby-GetText-Package-2.0.1 and the families
(gettext-2.0.1, gettext_activerecord-2.0.1 and gettext_rails-2.0.1)
are now available.

Ruby-GetText-Package is the library/tools for message localization.

  • gettext - Message localization libraries and tools for all kind of
    apps/libs.
  • gettext_activerecord - ActiveRecord Localization
  • gettext_rails - Rails support with gettext.

Changes

  • gettext-2.0.1

    • Fixed bugs
      • doesn’t work with ruby-1.8.5. [Reported by Dan Coutu]
      • GetText.locale= can’t keep the locale. [Reported by Adam Ilan]
      • Break backward compatibility of bindtextdomain
        [Reported by Mamoru T.(#24947), Mathieu B.]
      • Other trivial fixes/improvement.
    • 1.8 times faster than 2.0.0.
    • GetText::LocalePath is separated from GetText::TextDomainManager.
      Improve to find the locale path.
  • Enhance to support ruby-1.9.x [by OZAWA Sakuro]

  • gettext_activerecord-2.0.1

    • parser.rb: skip anonymous classes [by TieTew]
  • gettext_rails-2.0.0

    • ActionMailer didn’t work. [Reported by Simone C.]
    • error_messages_for doesn’t have compatibility with original
      method. [by Adam Ilan]

(NOTE)

  • Rails-2.3.1 and earlier aren’t supported.

Thanks to

OZAWA Sakuro, Tietew, Dan Coutu, Adam Ilan, Mamoru T.,
Mathieu B., Simone C.

Website

ScreenShots

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs