Generate Model or Migration not getting 001_create.rb


#1

When I run “ruby script/generate model users” or “ruby script/generate
migration users” (just as a test to see what number the migrations is
going to give me as a first run on a newly created project) I get
something like

20081026044945_create_users.rb

when it should be

001_create_users.rb

Man, I have been trying to figure this out all day. I uninstalled
rails and re-installed and tried all kinds of stuff and I cant seem to
get this to work.

I am using Eclipse as my IDE with the APTANA plugin. I have ruby 1.8
installed and rails 2 .x.x installed.

Has anyone else had this problem. I cant seem to find an answer from a
past post.

Thanks!


#2

There is nothing wrong. This is the new way Rails 2.x creates migration.
It doesn’t seem like it, but it is in fact much easier to maintain.

PS: in the future, don’t flood the list with the exact same question.


#3

Yea sorry about that. It took over 2 hours for the first one to come
up. I thought it didn’t go through.

On Oct 26, 4:05 am, Fernando P. removed_email_address@domain.invalid