Gen 2 Reader

Hello everybody,

I’ve been trying to set up the RFID-Reader by Michael Buettner and David
Wetherall as described in the paper “A Flexible Radio Software
Transceiver for UHF RFID Experimentation”. Following the instructions
from worked fine for me. When I wanted to
read several RFID-tags of different companies, the log files either had
no entries about read tags or the error “RN16 w/[different numbers]”

Furthermore I noticed many "uOuOuO"s while running the program. This is
an indicator of USRP overruns. I’m not quite sure if this is causing my
problem described above or if this is irrelevant. Searching the
internet, the gnuradio homepage stated “In our best case, we sustain
32MB/s across the USB”, so I ran to determine the
throughput of my USRP1 board with 2 attached FLEX900 daughterboards.
Surprisingly the throughput is 32MB/s, so this path was a dead end.

I’m using gnuradio 3.2.2 as I was not able to set up 3.4.0 (which is
recommended by the README of the gen2_reader). My os is Ubuntu 10.04.

Thank you in advance!