Gems, Proxy authentication

Hello… My company recently changed to a new proxy server and now my gem
update commands aren’t working. Doing a gem update gives me:

Updating installed gems
ERROR: While executing gem … (Zlib::BufError)
buffer error

I searched and found the rubysspi gem
(http://rubyforge.org/projects/rubysspi/
). I installed it and configured as per the directions and set my
http_proxy environment var:

set http_proxy=http://192.168.4.3:3128

(I also edited the gem.bat command to automatically include the library
-rspa)

But now I get:

Updating installed gems
ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
bad response Proxy Authentication Required 407
(http://gems.rubyforge.org/la
test_specs.4.8)

I’m not sure what the problem is or what to do to fix! Justin B. you
out there?

Thanks!

John T. wrote:

Hello… My company recently changed to a new proxy server and now my gem
update commands aren’t working.

Small update. I tried running the gem command like this:

ruby -rspa c:\ruby\bin\gem update

and it returns:

Updating installed gems
ERROR: While executing gem … (RuntimeError)
Error occurred during proxy negotiation. req: “NTLM
TlRMTVNTUAABAAAAt4II4gAA
AAAAAAAAAAAAAAAAAAAFASgKAAAADw==”; res:
#<Net::HTTPProxyAuthenticationRequired 4
07 Proxy Authentication Required readbody=true>; Original message:
Error: SEC_E_
INVALID_TOKEN

Yeah, not any better…

John T. wrote:

Hello… My company recently changed to a new proxy server and now my gem
update commands aren’t working. Doing a gem update gives me:

Updating installed gems
ERROR: While executing gem … (Zlib::BufError)
buffer error

I searched and found the rubysspi gem
(http://rubyforge.org/projects/rubysspi/
). I installed it and configured as per the directions and set my
http_proxy environment var:

set http_proxy=http://192.168.4.3:3128

(I also edited the gem.bat command to automatically include the library
-rspa)

But now I get:

Updating installed gems
ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
bad response Proxy Authentication Required 407
(http://gems.rubyforge.org/la
test_specs.4.8)

I’m not sure what the problem is or what to do to fix! Justin B. you
out there?

Thanks!

Hi, me too :frowning:
I set http_proxy environment var and after executing

gem list -r

I got:
*** REMOTE GEMS***
Error: While executing gem … (Gem::RemoteSourceException)
HTTP Responce 407

can you help me to overcome that evil proxy?
Is there a gem with topnotch proxy support?

Thank you for your attention.

Zhoran T. wrote:

Hi, me too :frowning:
I set http_proxy environment var and after executing

gem list -r

I got:
*** REMOTE GEMS***
Error: While executing gem … (Gem::RemoteSourceException)
HTTP Responce 407

can you help me to overcome that evil proxy?
Is there a gem with topnotch proxy support?

Thank you for your attention.

I was finally able to get it to work by including the username and
password in the environment var:

HTTP_PROXY=http://username:[email protected]:1234

(replace username, password and proxy address/port as necessary)

that made it work. I just have to remember to change it when I have to
change my password, every 90 days…

John T. wrote:

I was finally able to get it to work by including the username and
password in the environment var:

HTTP_PROXY=http://username:[email protected]:1234

(replace username, password and proxy address/port as necessary)

that made it work. I just have to remember to change it when I have to
change my password, every 90 days…

Hi, John!
So did I, but unsuccessful :frowning:
Stil got err 407 auth required

Tryied to set http_proxy = ‘domain\username:[email protected]:3128’
but uri\common.rb reported BAD URI …

setting http_proxy = ‘domain\username:[email protected]:3128’ makes
the same

I work with:

Ruby Installer for Windows
Ruby Version 1.8.6
Installer Version 186-25

    RELEASE NOTES

Contents: Version:


ruby-mswin32 ruby-1.8.6
zlib-lib 1.2.3
ZLib 0.6.0
RubyGems 0.9.2
Rake 0.7.2
RubySrc 1.8.6
FXRuby 1.6.6
FXri 0.3.6
SciTE 1.72
OpenGL 0.23b
GLUT 3.7.6
SWin 060205
VRuby 060223
Expat 2.0.0
XMLParser 0.6.8
Hpricot 0.4
RubyDBI 0.1.1
DBD/ODBC 0.9994
windows-pr 0.6.2
win32-file-stat 1.2.3
win32-file 0.5.3
win32-clipboard 0.4.1
win32-dir 0.3.1
win32-eventlog 0.4.3
win32-process 0.5.1
win32-sapi 0.1.3
win32-sound 0.4.0
log4r 1.0.5
Programming Ruby 1st Edition
OpenSSL 0.9.8d
Iconv 1.8
readline 4.3-2
PDCurses 2.60-1
GDBM 1.8.3-1
Installer-Patches 1.8.5

what is yours?

Zhoran T. wrote:

John T. wrote:
Tryied to set http_proxy = ‘domain\username:[email protected]:3128’
but uri\common.rb reported BAD URI …

sorry, shure actually they were
http://username:[email protected]:3128
http://domain\username:[email protected]:3128
http://domain\username:[email protected]:3128

Hm. Not sure. The first one you list below did work for me. I didn’t
have to include the domain.

Try typing the ‘env’ command to list the environment variables - there
is one defined for me:

USERDOMAIN=mydomain

It should already be set, and I don’t know if that’s used. Also I did
install that rubysspi gem, but am not sure if that’s helping or not…

Zhoran T. wrote:

Zhoran T. wrote:

John T. wrote:
Tryied to set http_proxy = ‘domain\username:[email protected]:3128’
but uri\common.rb reported BAD URI …

sorry, shure actually they were
http://username:[email protected]:3128
http://domain\username:[email protected]:3128
http://domain\username:[email protected]:3128

On Dec 10, 2008, at 07:11 AM, Zhoran T. wrote:

change my password, every 90 days…
makes
the same

Ruby does not support NTLM authentication by default which is what
your proxy probably uses. Maybe this will help:
http://rubyforge.org/projects/rubyntlm/

Eric H. wrote:

On Dec 10, 2008, at 07:11 AM, Zhoran T. wrote:

change my password, every 90 days…
makes
the same

Ruby does not support NTLM authentication by default which is what
your proxy probably uses. Maybe this will help:
http://rubyforge.org/projects/rubyntlm/

Hi, John.
I found out that proxy I had trouble with use ntlm authentication
indeed. I tested gem against the other proxy which accepts both ntlm and
basic authentication and it let gem through. I use env var http_proxy
with user and password set as you suggested Eric. Thank you guys! My
trouble is over :slight_smile:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs