Gems on AIX


#1

I’m attempting to build rubygems on AIX. It’s failing with:

/afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require__': No such file to load -- zlib (LoadError) from /afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from
/afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:9
from
/afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require__' from /afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from
/afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/builder.rb:1
from
/afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require__' from /afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from
/afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:61:in
manage_gems' ... 7 levels... from setup.rb:887:inexec_install’
from setup.rb:705:in invoke' from setup.rb:674:ininvoke’
from setup.rb:1352

Help?

– Matt
Nothing great was ever accomplished without passion


#2

you need to install the prerequisite ‘zlib’ library first

— Ursprüngliche Nachricht —
Von: Matt L. removed_email_address@domain.invalid
An: removed_email_address@domain.invalid (ruby-talk ML)
Betreff: gems on AIX
Datum: Wed, 16 Nov 2005 04:42:27 +0900

I’m attempting to build rubygems on AIX. It’s failing with:

/afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in

`require__’: No such file to load – zlib (LoadError)
from

/afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in

`require’
from
/afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:9
from

/afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in

`require__’
from

/afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in

`require’
from
/afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/builder.rb:1
from

/afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in

`require__’
from

/afs/austin/u/mattlaw/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in


#3

Hi,

On Tue, 15 Nov 2005 20:42:27, Matt L. removed_email_address@domain.invalid
wrote:

I’m attempting to build rubygems on AIX. It’s failing with:

`require__’: No such file to load – zlib (LoadError)
Help?

If I remember correctly, you have to compile ruby with the zlib
extension,
which fails if you don’t have zlib libs in your lib path.
maybe www.zlib.net

Kash