Gems Issue

Hello:

I’m trying to install a gem package, but its not working. Here’s what
I see:

C:>“c:\ruby\bin\ruby.exe” “c:\ruby\bin\gem” install --remote ruby-
activeldap
Attempting remote installation of ‘ruby-activeldap’
Install required dependency log4r? [Yn] Y
ERROR: While executing gem … (OpenURI::HTTPError)
404 Not Found

From what I’ve read, some say this means the gems repository is
temporarily off-line or there are some network issues. I don’t think
this is the case though. I’ve tried on a number of occasions over the
last week with no success and I can access the repository listing just
fine.

I’ve also seen some suggestion that I may need to upgrade my version
of ruby and/or gem. I’m a little reticent to do this, but I will if
someone can tell me with some certainty this is the issue. Here are
the versions I’m currently running:

C:>ruby -v
ruby 1.8.2 (2004-12-25) [i386-mswin32]

C:>gem -v
C:>“c:\ruby\bin\ruby.exe” “c:\ruby\bin\gem” -v
0.8.10

All suggestions are welcome. Thanks for your time.

On Mar 12, 3:29 pm, “bbiker” [email protected] wrote:

Have you tried “gem query -n ruby-activeldap -r” to verify that it exist if
it does you can “gem install ruby_activeldap” the -r is not necessary unless
you have a local copy of the gemspec

The correct syntax if “gem install ruby_activeldap -r”

Hi bbiker:

Thanks for the response.

It looks like I can see the gem package on the server. Here’s what I
see:

C:>gem query -n ruby-activeldap -r
C:>“c:\ruby\bin\ruby.exe” “c:\ruby\bin\gem” query -n ruby-activeldap -
r
*** REMOTE GEMS ***
ruby-activeldap (0.8.1, 0.8.0, 0.7.4, 0.7.3, 0.7.2, 0.7.1, 0.7.0,
0.6.0,
0.5.9, 0.5.8, 0.5.7, 0.5.5, 0.5.4, 0.5.3, 0.5.2, 0.5.1, 0.5.0, 0.4.4,
0.4.3,
0.4.2, 0.4.1)
Ruby/ActiveLdap is a object-oriented API to LDAP
ruby-activeldap-debug (0.7.4, 0.7.3, 0.7.2, 0.7.1, 0.7.0, 0.6.0,
0.5.9, 0.5.8,
0.5.7, 0.5.6, 0.5.5)
Ruby/ActiveLDAP is a object-oriented API to LDAP

This looks fine to me. So I tried to install it, but it still doesn’t
work. Here’s the output:

C:>gem install ruby-activeldap -r
C:>“c:\ruby\bin\ruby.exe” “c:\ruby\bin\gem” install ruby-activeldap -
r
Attempting remote installation of ‘ruby-activeldap’
Install required dependency log4r? [Yn] Y
ERROR: While executing gem … (OpenURI::HTTPError)
404 Not Found

The output is always failing on the log4r installation, so I tried to
only install this gem package. Again, it failed. Here’s the output:

C:>gem query -n log4r -r
C:>“c:\ruby\bin\ruby.exe” “c:\ruby\bin\gem” query -n log4r -r

*** REMOTE GEMS ***

log4r (1.0.5)
Log4r is a comprehensive and flexible logging library for Ruby.

C:>gem install log4r -r
C:>“c:\ruby\bin\ruby.exe” “c:\ruby\bin\gem” install log4r -r
Attempting remote installation of ‘log4r’
ERROR: While executing gem … (OpenURI::HTTPError)
404 Not Found

So for my own sanity, I decided to install a gem package for something
that I figure would have relatively few dependencies. I tried
rubytree. Here’s what I saw:

C:>gem query -n rubytree -r
C:>“c:\ruby\bin\ruby.exe” “c:\ruby\bin\gem” query -n rubytree -r
*** REMOTE GEMS ***
rubytree (0.2.3, 0.2.2)
Ruby implementation of the Tree data structure.

C:>gem install rubytree -r

C:>“c:\ruby\bin\ruby.exe” “c:\ruby\bin\gem” install rubytree -r
Attempting remote installation of ‘rubytree’
Successfully installed rubytree-0.2.3
Installing RDoc documentation for rubytree-0.2.3…

C:>

This one works with no fuss. So I’m still in the same place as before.
Any thoughts on how I can get this to work?

On Mar 12, 12:50 am, [email protected] wrote:

404 Not Found

someone can tell me with some certainty this is the issue. Here are
the versions I’m currently running:

C:>ruby -v
ruby 1.8.2 (2004-12-25) [i386-mswin32]

C:>gem -v
C:>“c:\ruby\bin\ruby.exe” “c:\ruby\bin\gem” -v
0.8.10

All suggestions are welcome. Thanks for your time.

Have you tried “gem query -n ruby-activeldap -r” to verify that it
exist
if it does you can “gem install ruby_activeldap” the -r is not
necessary unless you have a local copy of the gemspec

The correct syntax if “gem install ruby_activeldap -r”

C:\Documents and Settings\Owner>ruby -v
ruby 1.8.5 (2006-12-25 patchlevel 12) [i386-mswin32]

C:\Documents and Settings\Owner>gem -v
0.9.2

On Mar 18, 3:34 pm, [email protected] wrote:

Thanks for the response.
0.5.9, 0.5.8, 0.5.7, 0.5.5, 0.5.4, 0.5.3, 0.5.2, 0.5.1, 0.5.0, 0.4.4,

Attempting remote installation of ‘log4r’
rubytree (0.2.3, 0.2.2)

This one works with no fuss. So I’m still in the same place as before.
Any thoughts on how I can get this to work?

which version of ruby and gem?

C:\Documents and Settings\Owner>ruby -v
ruby 1.8.6 (2007-03-13 patchlevel 0) [i386-mswin32]

C:\Documents and Settings\Owner>gem -v
0.9.2

goto to: http://sourceforge.net/project/showfiles.php?group_id=43396
and download the log4r-1.0.5 gem file.

In the folder where you saved the gem, invoke gem install log4r -l

note you do NOT need to specify -r if the gem that you want to install
is not located in the current directory … gem searches the current
working directory for the specified gem, if not found then it
automatically does a remote search for the gem.

the -r option is used when you do not want to install the local copy

the -r option is used when you do not want to install the local copy
Hey bbiker:

Thanks for the reply. I was away for a bit so I’m just getting back to
this now.

I tried installing log4r locally. It took me a bit to get the
log4r-1.0.5.gem file. I couldn’t download it from any of the North
American sites, but it did come back from Ishikawa site. It installed
without issue. Once this was installed, I invoked a ‘gem install ruby-
activeldap’, and it installed successfully.

Thanks for the help!