.gemrc problem, installing Slave and Daemon on Railsmachine

While trying to install gems on my Railsmachine (hosted) server. The
“sudo gem install” command reported back “Killed” every time I tried
to install the Slave or Daemon gems (As part of getting BackgroundRB
rails plugin to work). With the --debug option on I got the following
information:

/usr/lib/site_ruby/1.8/rubygems/config_file.rb:51 - No such file or
directory - /home/deploy/.gemrc

so I added /home/deploy/.gemrc with the following information:

gemhome: /home/deploy/.gem
gempath:

  • /home/deploy/.gem
  • /user/lib/ruby/gems/1.8

But again “sudo gem install Slave --debug” ends into trouble:

Exception LoadError' at /usr/lib/site_ruby/1.8/rubygems/ custom_require.rb:27 - no such file to load -- Win32API ExceptionLoadError’ at /usr/lib/site_ruby/1.8/rubygems/
custom_require.rb:34 - no such file to load – Win32API
removing /tmp/open-uri3286.0…done
Bulk updating Gem source index for: http://gems.rubyforge.org
jremoving /tmp/open-uri3286.0…done
Killed

Does anyone have a clue?

Greetings,

Wilco

On Aug 20, 2007, at 23:35, [email protected] wrote:

While trying to install gems on my Railsmachine (hosted) server. The
“sudo gem install” command reported back “Killed” every time I tried
to install the Slave or Daemon gems (As part of getting BackgroundRB
rails plugin to work). With the --debug option on I got the following
information:

/usr/lib/site_ruby/1.8/rubygems/config_file.rb:51 - No such file or
directory - /home/deploy/.gemrc

–debug prints out every exception, even if caught. This exception
was caught.

Does anyone have a clue?

Likely you don’t have enough memory to do a bulk index update.

If you have a shared slice with limited RAM it is best if you use the
vendor/ directory or gem unpack locally then rsync to install what
you need.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs