Gem version issue prevent server starting


#1

Hi All,

I backed up my rails project and then reinstall Windows due to OS crash.
Then I install the latest Ruby, RubyGem, and Rails and copy back the
rails project. But now I cannot start the server (ruby script/server).
It gives the following message:

./script/…/config/boot.rb:26:Warning: Gem:SourceIndex#search support
for String patterns is deprecated Cannot find gem for Rails ~>1.3.1.0:
Install the missing gem with ‘gem install -v=1.3.1 rails’, or change
environment.rb to define RAILS_GEM_VERSION with your desired location.

I changed environment.rb’s RAILS_GEM_VERSION to 1.3.1 but it does not
have an effect. Then I tried to install the missing gem as listed above
(I think it is already installed but I try it anyway) and got the error
message: Could not find gem rails locally or in a depository.

How can I solve this problem? Should I start a new app for my existing
project?
Please enlighten. Thanks!


#2

Andreas,

RAILS_GEM_VERSION should match the version number of your installed
rails. i.e.: on my system,
rails --version gives Rails 2.2.2
thus, RAILS_GEM_VERSION = ‘2.2.2’ is correct.

1.3.1 is probably the version of gem you have installed

rick

On Dec 29, 11:13 am, kevin lee removed_email_address@domain.invalid


#3

Sorry about the name change Kevin…