"Gem::RubyGemsVersion" and gem -v don't match


#1

Hello,

  1. gem -v shows next: “1.3.1”
  2. my ruby&rails project has boot.rb file it contains next method
    def rubygems_version
    Gem::RubyGemsVersion rescue nil
    end
    this method is called in next code:
    def load_rubygems
    require ‘rubygems’
    min_version = ‘1.3.1’
    unless rubygems_version >= min_version
    $stderr.puts %Q(Rails requires RubyGems >= #{min_version} (you
    have #{rubygems_version}). Please gem update --system and try again.)
    exit 1
    end

Sometime when I open my project I have a window with next text “Rails
requires RubyGems >= 1.3.1 (you have 1.2.0). Please gem update --system and try again.”

Why Gem::RubyGemsVersion rescue nil gets “1.2.0” when I have “1.3.1”
version?? Any idea?

PS: This trouble doesn’t have any affect to work of project, but I
interest how(where) can I fix it?
PSS: start “gem update --system” says “Nothing to update”
PSSS: I’m novice in Ruby so please, expand your answer (:


#2

On 13 Jan 2009, at 23:18, Rred C. wrote:

Hello,

Do you have more than one install of ruby (eg one in /usr/bin, the
other in /usr/local/bin ?)

Fred


#3

Frederick C. wrote:

On 13 Jan 2009, at 23:18, Rred C. wrote:

Hello,

Do you have more than one install of ruby (eg one in /usr/bin, the
other in /usr/local/bin ?)

Fred

Hello Fred,
I think that was not present.
link (Ruby) and executable (Ruby1.8) was presented in /usr/bin, but
/usr/local/bin is empty.


#4

try installing the gem “rubygems-update” and then call “sudo
update_gems”.


#5

I had something similar, check your installations and paths…

Cheers, Sazima


#6

On Jan 14, 7:23 am, Rred C. removed_email_address@domain.invalid wrote:

Hello Fred,
I think that was not present.
link (Ruby) and executable (Ruby1.8) was presented in /usr/bin, but
/usr/local/bin is empty.

They could be in other places - those were just examples. Comparing
the output of
which gem
and
which ruby

might be enlightening.

Fred