Gem rails installs 3.2.2, doesn't seem to find my sprockets gem

So I was just doing a new gem install of rails and am encountering an
odd problem. Here’s what I am seeing.

gem install actionpack-3.2.2 -l
ERROR: While executing gem … (Gem::DependencyError)
Unable to resolve dependencies: actionpack requires sprockets (~>
2.1.2)

But I do have the sprockets-2.3.1 installed, which should be ~> 2.1.2,
proven by the below command

gem list --local | grep sprockets
sprockets (2.3.1)

What gives? Is this too new of a version?

On Mar 10, 12:14am, grant schoep [email protected] wrote:

proven by the below command

2.3.1 is not ~>2.1.2

~> 2.1.2 is equivalent to >= 2.1.2 and < 2.2
and so doesn’t match 2.3.1. It’s useful when you’re ok picking up new
versions with bug fixes but don’t want any breaking changes (assuming
that the gems you are using version themselves sensibly)

Fred

On Fri, Mar 9, 2012 at 5:14 PM, grant schoep [email protected]
wrote:

proven by the below command

gem list --local | grep sprockets
sprockets (2.3.1)

What gives? Is this too new of a version?

Ah, I figured out what the problem was. I tried this out on a computer
connected to the internet and let gem install automatically do its work.
On
install, It went ahead and grabbed sprocket-2.1.2 specifically.
Regardless
that I had 2.3.1 installed. Now it works fine.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs