Gem questions/problems


#1

I installed gem on a few machines (identical machines). When I do gem
list --remote on some of them, they dump a big list of packages. When I
do the same command on one of them, it returns nothing:

[root@devbox1 1.8]# gem list --remote

*** REMOTE GEMS ***
[root@devbox1 1.8]#

Anyone have an idea what’s going on? I tried reinstalling it a few times
already.

Also, when I do a gem list --remote rails, I dont see a version 1.2.3 on
there… nor do I see a rake 0.7.2. Could these packages just be too new
to be in a gem repo or is there some sort of list update that I need to
do?

Thanks!

(ruby noob here)


#2

On Mar 19, 3:23 pm, Mike H. removed_email_address@domain.invalid wrote:

to be in a gem repo or is there some sort of list update that I need to
do?

What happens when you just try to ‘gem install’ something? Does it
complain about sources? I remember having trouble with an older
version of rubygems where the installer wouldn’t install the sources
gem. But I don’t often use list --remote so I’m not sure if it’s the
same issue.
-Mat


#3

Hey,

I downloaded the gem for rake and it installed just fine using gem
install /path/to/rake-0.7.2.gem


#4

"What happens when you just try to ‘gem install’ something? "

if the gem isnt downloaded and i try this, yes it does complain:

gem install mongrel
ERROR: While executing gem … (Gem::GemNotFoundException)
Could not find mongrel (> 0) in any repository


#5

On Mar 19, 2007, at 12:23, Mike H. wrote:

Anyone have an idea what’s going on? I tried reinstalling it a few

Thanks!

What does ‘gem sources’ say?

What version of rubygems?