Gem problems: install "bulk updating..." gets oom killed: no memory


#1

Hello,

ruby 1.8.4, gems 1.0.1

On a 256MB VPS my gem installs blow up. I had this problem when the
VPS was at 128MB, then upgraded to 256 and it went away. But now it’s
happening again. It doesn’t matter how many processes I kill to make
free memory I still run out. This time around I can’t justify
upgrading the VPS.

I also can’t update the gem system in case this is a bug that’s been
fixed: the same thing happens.

Any help appreciated.


#2

2009/4/30 itsastickup removed_email_address@domain.invalid:

Hello,

ruby 1.8.4, gems 1.0.1

That version of gems is really old. The version on my box is 1.3.1. I
think there are some backwards incompatibilities between the newer and
older versions which can cause issues such as what you describe. See
if upgrading to a newer gems version helps.

Farrel


#3

Hello,

ruby 1.8.4, gems 1.0.1

That version of gems is really old. The version on my box is 1.3.1. I
think there are some backwards incompatibilities between the newer and
older versions which can cause issues such as what you describe. See
if upgrading to a newer gems version helps.

Thanks for that.

Is there a way of upgrading without the memory problems? I’ve tried
gem install <url to 1.3.1>

but it still insists on “Bulk updating…” and dies.


#4

Is there a way of upgrading without the memory problems? I’ve tried
gem install <url to 1.3.1>

but it still insists on “Bulk updating…” and dies.

So the solution seems to be to use the -B option to avoid the bulk
update feature. It then gets each one at a rate of 7 a second for
22,000: I had to wait an hour, but the following worked:

gem update --system -B 100000000


#5

On Apr 30, 2009, at 07:30, itsastickup wrote:

Is there a way of upgrading without the memory problems? I’ve tried
gem install <url to 1.3.1>

but it still insists on “Bulk updating…” and dies.

So the solution seems to be to use the -B option to avoid the bulk
update feature. It then gets each one at a rate of 7 a second for
22,000: I had to wait an hour, but the following worked:

gem update --system -B 100000000

You can also upgrade my manually upgrading, see the last set of
install instructions here:

http://rubyforge.org/forum/forum.php?forum_id=31661