GEM Problem

Hi guys im getting this error using gems on windows im behind a proxy
but i set it to work from the command line. So i really don’t know
what the problem is.

Thanks in advance

Error message

ERROR: While executing gem … (URI::InvalidURIError)
can not set user with registry or opaque

Hi,

   Actually I think the command line is the better way. The command

lines like “C:\Documents and Settings>gem install rails --remote” also
work
for me behind a proxy.
Maybe you can show more details about what you called “gems on
windows im”? You did not tell us much about it.

Enjoy!

Well im using gem in a Microsoft Windows cmd, i don’t know if its have
some problems with the environment or something like that.

Hi,

Pls pay attention to the points below:

  1. Did you use a firewall that might block gem’s communication? You can
    turn
    off your firewall to have a try.
  2. Did you set a correct env variable HTTP_PROXY? Or did you add the
    option
    “-p” to your gem command?
    -p, --[no-]http-proxy [URL] Use HTTP proxy for remote operations
  3. Can you ping urls like http://gems.rubyforge.org successfully?
    Hope you can succeed.

Rgds,

Rafael G. wrote:

No i can’t ping it, but that only means that icmp is blocked i thought
gems used HTTP connection, anyway is there another solution for me to
get rails and mongrel ?

When all else fails (your local proxying scheme is convoluted, some
obscure Internet Explorer only solution, authenticated, etc.), you can
always just download the gem files from http://gems.rubyforge.org/gems/,
and install them from the download folder using “gem install *.gem” - of
course, you have to resolve various dependencies yourself in that case.

David V.

On 11/3/06, shiwei zhang [email protected] wrote:

Hi,

Pls pay attention to the points below:

  1. Did you use a firewall that might block gem’s communication? You can turn
    off your firewall to have a try.
    I don’t have a local firewall.
  2. Did you set a correct env variable HTTP_PROXY? Or did you add the option
    “-p” to your gem command?
    Yes im using HTTP_PROXY, i tested with pear and its works fine.
    -p, --[no-]http-proxy [URL] Use HTTP proxy for remote operations
  3. Can you ping urls like http://gems.rubyforge.org successfully?
    No i can’t ping it, but that only means that icmp is blocked i thought
    gems used HTTP connection, anyway is there another solution for me to
    get rails and mongrel ?

Thanks in advance

Thanks, i’ll do that.

shiwei zhang wrote:

  Actually I think the command line is the better way. The command

lines like “C:\Documents and Settings>gem install rails --remote” also work
for me behind a proxy.

The proxy issue is completely and totally unrelated to how you use the
rubygems API. If you set your http_proxy environment variable to
http://yourproxyname:3128/, rubygems will pick it up.

David V.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs