Gem_original_require': no such file to load -- mime/types


#1

the gems mime_types and mini_magick are installed.

When i try to launch my application, i receive this error:
gem_original_require’: no such file to load – mime/types
(MissingSourceFile)

from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
require' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:inrequire’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
new_constants_in' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:inrequire’
from
/home/nerto/public_html/nerto/vendor/plugins/attachment_fu/lib/technoweenie/attachment_fu.rb:1
from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:382:in
load_without_new_constant_marking' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:382:inload_file’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
new_constants_in' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:381:inload_file’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:256:in
require_or_load' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:427:inload_missing_constant’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:77:in
const_missing' from /home/nerto/public_html/nerto/vendor/plugins/attachment_fu/init.rb:12:inevaluate_init_rb’
from
/usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/rails/plugin.rb:103:in
evaluate_init_rb' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/core_ext/kernel/reporting.rb:11:insilence_warnings’
from
/usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/rails/plugin.rb:99:in
evaluate_init_rb' from /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/rails/plugin.rb:44:inload’
from
/usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/rails/plugin/loader.rb:33:in
load_plugins' from /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/rails/plugin/loader.rb:32:ineach’
from
/usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/rails/plugin/loader.rb:32:in
load_plugins' from /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:323:inload_plugins’
from
/usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:160:in
process' from /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:112:insend’
from
/usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:112:in run' from /home/nerto/public_html/nerto/config/environment.rb:13 from /usr/lib/ruby/1.8/irb/init.rb:252:inrequire’
from /usr/lib/ruby/1.8/irb/init.rb:252:in load_modules' from /usr/lib/ruby/1.8/irb/init.rb:250:ineach’
from /usr/lib/ruby/1.8/irb/init.rb:250:in load_modules' from /usr/lib/ruby/1.8/irb/init.rb:21:insetup’
from /usr/lib/ruby/1.8/irb.rb:54:in `start’
from /usr/bin/irb:13

How can i resolve it?
thanks


#2

I think you need to add :lib => “mime/types” to your config.gem
statement.

Daniel

On Dec 17, 1:07 pm, Luca R. removed_email_address@domain.invalid