Gem_original_require': no such file to load -- blow/json (LoadError)

Trying to run the blog demo, can someone tell me what I’m missing?

[email protected] ~/src/repo.nitroproject.org/nitro/demo/blog $ nitro
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require’: no such file to load – blow/json (LoadError)

Thanks,
reid

On Dec 5, 11:59 am, Reid T. [email protected] wrote:

Trying to run the blog demo, can someone tell me what I’m missing?

[email protected] ~/src/repo.nitroproject.org/nitro/demo/blog $ nitro
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require’: no such file to load – blow/json (LoadError)

gem install blow

Note: blow is about to get a new release here in a day or so.

T.

On Wed, 2007-12-05 at 10:00 -0800, Trans wrote:

T.


Nitro-general mailing list
[email protected]
http://rubyforge.org/mailman/listinfo/nitro-general

Thanks,…
next issue…

[email protected] ~/src/repo.nitroproject.org/nitro/demo/blog $ ruby
./app.rb
REPO_ROOT is /home/rthompso/src/repo.nitroproject.org/script/lib/…/…
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require': no such file to load -- part/admin (LoadError) from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from ./app.rb:11
[email protected] ~/src/repo.nitroproject.org/nitro/demo/blog $ env|grep -i
NITRO
OLDPWD=/home/rthompso/src/repo.nitroproject.org
NITRO_HOME=/home/rthompso/src/repo.nitroproject.org
PATH=/home/rthompso/src/repo.nitroproject.org/nitro/bin:/home/rthompso/bin:/usr/lib/ccache/bin:/usr/lib/ccache/bin:/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.1.2:/opt/ghc/bin:/usr/kde/3.5/bin:/usr/qt/3/bin:/opt/Adbobe/Reader8/bin:/opt/fltk/bin:/opt/dillo/bin:/usr/games/bin:/opt/vmware/server/console/bin:/var/spool/fax/bin:/opt/snav/bin:/home/rthompso/bin/eclipse:/home/rthompso/netbeans-6.0-200710020000/bin/:/usr/libexec/cssc
PWD=/home/rthompso/src/repo.nitroproject.org/nitro/demo/blog
[email protected] ~/src/repo.nitroproject.org/nitro/demo/blog $ env|grep
RUBYOPT
RUBYOPT=-rubygems
[email protected] ~/src/repo.nitroproject.org/nitro/demo/blog $

Reid T. schreef:

Try this:

RUBYOPT="-rubygems -I$NITRO_HOME" ruby app.rb

(ab)

Nitro-general mailing list
[email protected]
http://rubyforge.org/mailman/listinfo/nitro-general


Arne B.
http://www.arnebrasseur.net
http://www.zhongwiki.com
http://www.bankske.org
[email protected]

Reid T. schreef:

    from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    from app.rb:11

Oops, that should’ve been:

RUBYOPT="-rubygems -I$NITRO_HOME/part/lib" ruby app.rb

which might or might not get things rolling. I get a similar error over
here that it can’t find tmail. It’s getting late over here but I’ll get
back to you tomorrow on this with more detail. Running these examples
should be a fault-free one-liner before 0.50 is released. I’ll look into
it.

You mentioned before you were willing to review and test-drive
documentation, does that still hold?

Thank you,
(ab)

On Thu, 2007-12-06 at 15:14 +0800, Arne B. wrote:

    from ./app.rb:11

Try this:

RUBYOPT="-rubygems -I$NITRO_HOME" ruby app.rb

[email protected] ~/src/repo.nitroproject.org/nitro/demo/blog $
RUBYOPT="-rubygems -I$NITRO_HOME" ruby app.rb
REPO_ROOT is /home/rthompso/src/repo.nitroproject.org/script/lib/…/…
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require': no such file to load -- part/admin (LoadError) from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from app.rb:11

[email protected] ~/src/repo.nitroproject.org/nitro/demo/blog $ echo
$NITRO_HOME
/home/rthompso/src/repo.nitroproject.org

[email protected] ~/src/repo.nitroproject.org $ pwd
/home/rthompso/src/repo.nitroproject.org

[email protected] ~/src/repo.nitroproject.org $ ls -lrt
total 8
drwxr-xr-x 7 rthompso staff 216 Dec 5 12:11 _darcs
drwxr-xr-x 2 rthompso staff 240 Dec 5 12:11 rake_tasks
-rw-r–r-- 1 rthompso staff 46 Dec 5 12:11 Rakefile
drwxr-xr-x 3 rthompso staff 96 Dec 5 12:11 script
drwxr-xr-x 8 rthompso staff 280 Dec 5 12:11 raw
drwxr-xr-x 4 rthompso staff 120 Dec 5 12:11 part
drwxr-xr-x 9 rthompso staff 304 Dec 5 12:11 og
drwxr-xr-x 9 rthompso staff 304 Dec 5 12:11 nitro
drwxr-xr-x 8 rthompso staff 304 Dec 5 12:11 glue
-rw-r–r-- 1 rthompso staff 23 Dec 5 12:11 README

On Thu, 2007-12-06 at 23:45 +0800, Arne B. wrote:

/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require’: no such file to load – part/admin (LoadError)
I’ll get back to you tomorrow on this with more detail. Running these
examples should be a fault-free one-liner before 0.50 is released.
I’ll look into it.

thanks much.

results…

had to install opod also.

** app started up ok then. Success!! **

One thing to document for those running from darcs is a list of other
required packages…

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs