Gem list --remote does not work on windows running ruby 1.9.2p0

Title says all.
This q is mainly for LuisL, but maybe someone has encountered it
already…
I plan to modify gem.bat, but maybe there is a better way, so the q…

many thanks to Luis for a great ruby package for windows.

best regards -botp

sample run…

C:\downloads>gem list --remote

*** REMOTE GEMS ***

ERROR: While executing gem … (Errno::ENOENT)
No such file or directory - C:/Documents and Settings/PeñaIJM

C:\downloads>
C:\downloads>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

C:\downloads>gem list

*** LOCAL GEMS ***

minitest (1.6.0)
rake (0.8.7)
rdoc (2.5.8)

C:\downloads>gem list --remote

*** REMOTE GEMS ***

ERROR: While executing gem … (Errno::ENOENT)
No such file or directory - C:/Documents and Settings/PeñaIJM

On Aug 24, 7:33 am, botp [email protected] wrote:

C:\downloads>gem list --remote
C:\downloads>gem list

ERROR: While executing gem … (Errno::ENOENT)
No such file or directory - C:/Documents and Settings/PeñaIJM

When reporting issues related to RubyGems, please provide the
following:

  1. Complete output of “gem env”

  2. Complete output of the command that triggers the error including “–
    debug -V” options.

Preferable, provide a gist or pastie with it.

I can’t reproduce, it works for me:

http://gist.github.com/547401

And then more than 3 thousands rows…

On Aug 24, 7:33 am, botp [email protected] wrote:

ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

It is worth mentioning that your username contains accented
characters.

RubyGems itself don’t have an specific test for that, since it assumes
Ruby handles it.

Ruby 1.9.2 has improved unicode support for file management, but it
might be an oversight in this case.

Please provide the information I’ve requested on my previous post.

Also, the gems you listed are bundled with Ruby, so doing gem list
will not trigger anything as these gems are inside Ruby.

On Tue, Aug 24, 2010 at 7:45 PM, Luis L. [email protected]
wrote:

It is worth mentioning that your username contains accented characters.
RubyGems itself don’t have an specific test for that, since it assumes
Ruby handles it.
Ruby 1.9.2 has improved unicode support for file management, but it
might be an oversight in this case.

ah, yes.

if that is the case, i may need to adjust but i’d like to know the
best way. changing my userid is close to remote since i do not dictate
my login id here… we login w our real name ie…

thank you and best regards -botp

On Aug 25, 12:41 am, botp [email protected] wrote:

best way. changing my userid is close to remote since i do not dictate
my login id here… we login w our real name ie…

thank you and best regards -botp

Did you installed ruby with admin rights? Because gem env shows the
right information.

Try setting HOME using setx command to a folder without spaces.

On Tue, Aug 24, 2010 at 7:40 PM, Luis L. [email protected]
wrote:

  1. Complete output of “gem env”
  2. Complete output of the command that triggers the error including “-- debug -V” options.

Hi Luis,

here goes…

C:\Documents and Settings\PeñaIJM>gem env
RubyGems Environment:

  • RUBYGEMS VERSION: 1.3.7
  • RUBY VERSION: 1.9.2 (2010-08-18 patchlevel 0) [i386-mingw32]
  • INSTALLATION DIRECTORY: C:/Ruby192/lib/ruby/gems/1.9.1
  • RUBY EXECUTABLE: C:/Ruby192/bin/ruby.exe
  • EXECUTABLE DIRECTORY: C:/Ruby192/bin
  • RUBYGEMS PLATFORMS:
    • ruby
    • x86-mingw32
  • GEM PATHS:
    • C:/Ruby192/lib/ruby/gems/1.9.1
  • GEM CONFIGURATION:
    • :update_sources => true
    • :verbose => true
    • :benchmark => false
    • :backtrace => false
    • :bulk_threshold => 1000
  • REMOTE SOURCES:

C:\Documents and Settings\PeñaIJM>gem list --remote --debug -V
Exception `NameError’ at
C:/Ruby192/lib/ruby/1.9.1/rubygems/command_manager.rb:164

  • uninitialized constant Gem::Commands::ListCommand

*** REMOTE GEMS ***

Exception `Errno::ENOENT’ at
C:/Ruby192/lib/ruby/1.9.1/rubygems/spec_fetcher.rb:47

  • No such file or directory - C:/Documents and Settings/PeñaIJM
    ERROR: While executing gem … (Errno::ENOENT)
    No such file or directory - C:/Documents and Settings/PeñaIJM
    C:/Ruby192/lib/ruby/1.9.1/rubygems/spec_fetcher.rb:47:in stat' C:/Ruby192/lib/ruby/1.9.1/rubygems/spec_fetcher.rb:47:ininitialize’
    C:/Ruby192/lib/ruby/1.9.1/rubygems/spec_fetcher.rb:38:in new' C:/Ruby192/lib/ruby/1.9.1/rubygems/spec_fetcher.rb:38:infetcher’
    C:/Ruby192/lib/ruby/1.9.1/rubygems/commands/query_command.rb:112:in
    execute' C:/Ruby192/lib/ruby/1.9.1/rubygems/commands/list_command.rb:31:inexecute’
    C:/Ruby192/lib/ruby/1.9.1/rubygems/command.rb:270:in invoke' C:/Ruby192/lib/ruby/1.9.1/rubygems/command_manager.rb:134:inprocess_args’
    C:/Ruby192/lib/ruby/1.9.1/rubygems/command_manager.rb:104:in
    run' C:/Ruby192/lib/ruby/1.9.1/rubygems/gem_runner.rb:58:inrun’
    C:/Ruby192/bin/gem:21:in `’

C:\Documents and Settings\PeñaIJM>

note, this is fresh/pristine install of ruby. no previous ruby ie…

best regards -botp

On Aug 25, 2:38 am, botp [email protected] wrote:

HOMEDRIVE and HOMEPATH is part of the system, you shouldn’t be
removing those :stuck_out_tongue:

What was HOME set to?

On Windows XP I used to map my user directory to another drive and
configured USERPROFILE (in User administration) to that drive.

Vista and now 7 uses user folders without spaces, thank god.

btw, Luis, can i install ruby as an ordinary user (no admin ie) and
just place ruby under my win home folder… akin to what rvm does on
linux…

That is how I have installed Ruby (actually using the 7-zip packages
of RubyInstaller).

However, please avoid having path with spaces as your home directory.

C:\Users\Luis\Projects\oss\oci\rubyinstaller>where ruby
C:\Users\Luis\Tools\Ruby\ruby-1.8.7-p302-i386-mingw32\bin\ruby.exe

On Wed, Aug 25, 2010 at 11:35 PM, Luis L. [email protected]
wrote:

HOMEDRIVE and HOMEPATH is part of the system, you shouldn’t be
removing those :stuck_out_tongue:

well if the going gets tough, the brain fa*rts :slight_smile:

What was HOME set to?

none. i have no home var

On Windows XP I used to map my user directory to another drive and
configured USERPROFILE (in User administration) to that drive.

i would prefer lesser config that requires admin. i’m just lucky here
since i’m close to the admins… but they’re always busy so…

Vista and now 7 uses user folders without spaces, thank god.

wow didn’t know that. i am still stuck at xp after a bad vista
experience.

btw, Luis, can i install ruby as an ordinary user (no admin ie) and
just place ruby under my win home folder… akin to what rvm does on
linux…

That is how I have installed Ruby (actually using the 7-zip packages
of RubyInstaller).

ah, the zip packs. thanks, Luis.

However, please avoid having path with spaces as your home directory.

C:\Users\Luis\Projects\oss\oci\rubyinstaller>where ruby
C:\Users\Luis\Tools\Ruby\ruby-1.8.7-p302-i386-mingw32\bin\ruby.exe

yes, wish i could touch the root folder anytime. maybe time to go to win
7 :slight_smile:


Luis L.

thank you and best regards -botp

On Wed, Aug 25, 2010 at 12:30 PM, Luis L. [email protected]
wrote:

Did you installed ruby with admin rights? Because gem env shows the right information.
Try setting HOME using setx command to a folder without spaces.

this is weird.
out of desperation, i removed all home vars (eg homepath…) and it
works. i was even able to update

… just wondering now how it would affect other win apps that depends
on homepath, etc…

btw, Luis, can i install ruby as an ordinary user (no admin ie) and
just place ruby under my win home folder… akin to what rvm does on
linux…

thanks and kind regards -botp

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs